Attempt to fix missing branch parameter for force building windows builds
[blender-buildbot.git] / master.cfg
index a054086d431090870de1e599f20f8a598e5bd10e..2f4a57248c27a762c384692f8c6ba04786a18770 100644 (file)
@@ -12,6 +12,9 @@ FORCE_SCHEDULE_BRANCHES = ["master", "blender2.8", "experimental-build"]
 # List of branches availble for addons branch selection.
 ADDONS_BRANCHES = ["master", "blender2.8"]
 
+# List of branches availble for libraries branch selection.
+LIB_BRANCHES = ["trunk"]
+
 # Dictionary that the buildmaster pays attention to.
 c = BuildmasterConfig = {}
 
@@ -122,8 +125,22 @@ def schedule_force_build(name):
                        hide=True,
                        codebase="blender-dev-tools"),
                    forcesched.CodebaseParameter(
-                       hide=True,
-                       codebase="lib svn")],
+                       codebase="lib svn",
+                       branch=forcesched.ChoiceStringParameter(
+                           name="branch",
+                           choices=LIB_BRANCHES,
+                           default="trunk"),
+                       repository=forcesched.FixedParameter(name="repository",
+                                                            default="",
+                                                            hide=True),
+                       project=forcesched.FixedParameter(name="project",
+                                                         default="",
+                                                         hide=True),
+                       revision=forcesched.FixedParameter(name="revision",
+                                                          default="",
+                                                          hide=True),
+                   ),
+        ],
         properties=[]))
 
 
@@ -338,14 +355,14 @@ c['projectName'] = "Blender"
 c['projectURL'] = "https://www.blender.org"
 
 # Buildbot information
-c['buildbotURL'] = "https://builder.blender.org/"
+c['buildbotURL'] = "https://builder.blender.org/admin/"
 c['buildbotNetUsageData'] = 'basic'
 
 # Various
 c['db_url'] = "sqlite:///state.sqlite"
 
 c['title'] = "Blender"
-c['titleURL'] = "https://builder.blender.org/admin/"
+c['titleURL'] = "https://builder.blender.org/"
 
 # Disable sending of 'buildbotNetUsageData' for now, to improve startup time.
 c['buildbotNetUsageData'] = None