Adds ffmpeg-support on Linux-platforms. Since ffmpeg is installed
[blender-staging.git] / intern / elbeem / SConscript
1 #!/usr/bin/python
2 import sys
3 Import('env')
4  
5 #if use_fluidsim=='false':
6 #   # print "El'Beem Fluid Simulation Disabled..." # debug
7 #   elbeem_env.Append (CPPPATH = user_options_dict['PNG_INCLUDE'])
8 #   elbeem_env.Append (CPPPATH = user_options_dict['SDL_INCLUDE'])
9 #   elbeem_env.Append(CPPDEFINES= 'ELBEEM_DUMMIES');
10 #   # dummy interface build
11 #   Sources = [ 
12 #       "intern/utilities.cpp",
13 #       "intern/blenderdummy.cpp"
14 #           ]; # sources
15
16 sources = env.Glob('intern/*.cpp')
17
18 defs = 'NOGUI ELBEEM_BLENDER=1'
19 if env['OURPLATFORM']=='win32-vc':
20     defs += ' USE_MSVC6FIXES'
21 incs = env['BF_PNG_INC'] + ' ' + env['BF_ZLIB_INC'] + ' ' +env['BF_SDL_INC']
22
23 env.BlenderLib ('blender_elbeem', sources, Split(incs), Split(defs), libtype='blender', priority=0 )