unify include guard defines, __$FILENAME__
[blender-staging.git] / intern / ffmpeg / ffmpeg_compat.h
index 582086d130b0b45db518616390ab07a8e0894a78..bb2c4f2d0a422f305eec9a2751f46aa07d75cadf 100644 (file)
@@ -1,8 +1,4 @@
-#ifndef __ffmpeg_compat_h_included__
-#define __ffmpeg_compat_h_included__ 1
-
 /*
- *
  * compatibility macros to make every ffmpeg installation appear
  * like the most current installation (wrapping some functionality sometimes)
  * it also includes all ffmpeg header files at once, no need to do it 
  *
  */
 
+#ifndef __FFMPEG_COMPAT_H__
+#define __FFMPEG_COMPAT_H__
 
 #include <libavformat/avformat.h>
 
-
 /* check our ffmpeg is new enough, avoids user complaints */
 #if (LIBAVFORMAT_VERSION_MAJOR < 52) || ((LIBAVFORMAT_VERSION_MAJOR == 52) && (LIBAVFORMAT_VERSION_MINOR <= 64))
 #  error "FFmpeg 0.7 or newer is needed, Upgrade your FFmpeg or disable it"