fix for warnings & detecting opensource nouveau drivers.
[blender-staging.git] / source / blender / gpu / intern / gpu_extensions.c
index 49f9fbebf5641ccf66cfdaa0cc02c9eeba36a1a5..70a74aafead7247731135288062f1598a2062f1a 100644 (file)
@@ -135,7 +135,7 @@ void GPU_extensions_init()
                GG.device = GPU_DEVICE_ATI;
                GG.driver = GPU_DRIVER_OPENSOURCE;
        }
-       else if(strstr(renderer, "Nouveau")) {
+       else if(strstr(renderer, "Nouveau") || strstr(vendor, "nouveau")) {
                GG.device = GPU_DEVICE_NVIDIA;
                GG.driver = GPU_DRIVER_OPENSOURCE;
        }