more sensible defaults for new scons on Os X :
authorJean-Luc Peurière <jlp@nerim.net>
Sat, 4 Feb 2006 22:16:01 +0000 (22:16 +0000)
committerJean-Luc Peurière <jlp@nerim.net>
Sat, 4 Feb 2006 22:16:01 +0000 (22:16 +0000)
commit727f832003acb75a40045b3a8fbd2a9f7fc96baf
tree86155770ca0f0225e85f68ab0ca9a65d6e086650
parent4e82647e86b9de7a30d5035f49cf34f00fbe1934
more sensible defaults for new scons on Os X :

- python 2.3   if you want python 2.4 add the 2 following lines in
               user-config.py :
              BF_PYTHON = '2.3'
              BF_PYTHON = '/library.Frameworks/Python.framework/Versions/'

- disabled libtiff by default. new scons force lib linking &  it shouldnt
  will work on that
- added SystemStubs lib that 10.4 require in some circumstances.
  10.3 users may have to remove it with this line :
              LLIBS = 'stdc++'

additional notes :

OpenEXR libs and includes are searched in /usr/local
use by preference gcc3.3 gcc4 need some new libs i will commit shortly
you get in final an unpackaged binary. take a previous blender app  and use
show package content command to navigate to Contents/MacOs. replace the
binary there by new one, and voila, you have a working new app.

will commit shortly the automatic packager
config/darwin-config.py