making PO/POT/... update scripts py3.2 compatible + making it almost win compatible
authorDalai Felinto <dfelinto@gmail.com>
Thu, 29 Sep 2011 06:34:58 +0000 (06:34 +0000)
committerDalai Felinto <dfelinto@gmail.com>
Thu, 29 Sep 2011 06:34:58 +0000 (06:34 +0000)
commit9701a58fecb7f8a690dacb44c248969c653dbc4b
tree08dd4a7229d3943ef463ff6917310a7d4257570f
parent9465efd401474c40d45b9943111a68f502832f5f
making PO/POT/... update scripts py3.2 compatible + making it almost win compatible

Adding from codecs import open + the encoding in update_pot.py so it works for python 3.2.
Now it should be easier to replace the executable folders in the first lines of the file.
It now also works if you are in the same folder as the .po files (i.e. os.path.dirname(__FILE__) is empty)

It's still not working for me on Mingw because I need gettext 1.8 and so far I found only the 1.7
(in 1.7 msgmerge --lang is not supported)
po/update_mo.py
po/update_msg.py
po/update_po.py
po/update_pot.py