Fix T47939: Install Deps OSL 1.7.1 and clang-3.5
authorBastien Montagne <montagne29@wanadoo.fr>
Fri, 25 Mar 2016 23:31:41 +0000 (00:31 +0100)
committerBastien Montagne <montagne29@wanadoo.fr>
Fri, 25 Mar 2016 23:31:41 +0000 (00:31 +0100)
Until we officially support llvm3.5 or more, only allow for 3.4 llvm packages,
and build own stuff otherwise...

build_files/build_environment/install_deps.sh

index d069bfa93ca7fd91ffbc628fe7e6fcc9e1826ce0..00e8168f2562aa2d9d654f96359598d6ccaf0f16 100755 (executable)
@@ -2649,15 +2649,15 @@ install_DEB() {
       LLVM_VERSION_FOUND=$LLVM_VERSION
       clean_LLVM
     else
-      check_package_version_ge_DEB llvm-dev $LLVM_VERSION_MIN
-      if [ $? -eq 0 ]; then
-        install_packages_DEB llvm-dev clang
-        have_llvm=true
-        LLVM_VERSION_FOUND=""  # Using default one, no need to specify it!
-        clean_LLVM
-      else
-        _do_compile_llvm=true
-      fi
+      #~ check_package_version_ge_DEB llvm-dev $LLVM_VERSION_MIN
+      #~ if [ $? -eq 0 ]; then
+        #~ install_packages_DEB llvm-dev clang
+        #~ have_llvm=true
+        #~ LLVM_VERSION_FOUND=""  # Using default one, no need to specify it!
+        #~ clean_LLVM
+      #~ else
+      _do_compile_llvm=true
+      #~ fi
     fi
   fi
 
@@ -3563,7 +3563,7 @@ install_ARCH() {
     INFO "Forced LLVM building, as requested..."
     _do_compile_llvm=true
   else
-    check_package_version_ge_ARCH llvm $LLVM_VERSION_MIN
+    check_package_version_match_ARCH llvm $LLVM_VERSION
     if [ $? -eq 0 ]; then
       install_packages_ARCH llvm clang
       have_llvm=true