Fix #28154: linux3-config.py doesn't exist
[blender.git] / source / blender / blenpluginapi / SConscript
1 #!/usr/bin/python
2 Import ('env')
3
4 sources = env.Glob('intern/*.c')
5
6 incs = '. .. #/intern/guardedalloc ../blenlib ../imbuf ../makesdna ../blenloader'
7
8 defs = []
9
10 if env['WITH_BF_QUICKTIME']:
11     defs.append('WITH_QUICKTIME')
12     incs += ' ' + env['BF_QUICKTIME_INC']
13
14 if env['OURPLATFORM'] == 'linux':
15     cflags='-pthread'
16     incs += ' ../../../extern/binreloc/include'
17
18 if env['OURPLATFORM'] in ('win32-vc', 'win32-mingw', 'linuxcross', 'win64-vc'):
19     incs += ' ' + env['BF_PTHREADS_INC']
20
21 env.BlenderLib ( libname = 'bf_blenpluginapi', sources = sources, includes = Split(incs), defines = defs, libtype=['core'], priority = [170] )