Added the the magic compiler flag that will turn on game-engine integration with...
[blender.git] / README
1 Welcome to the fun world of open-source.
2
3 This file is to help you get started using the source and will hopefully
4 answer most questions.
5
6 Here are some links to external packages you may or maynot need:
7
8 openssl:  http://www.openssl.org
9 python:  http://www.python.org
10 mxtexttools:http://www.egenix.com/files/python/mxTextTools.html (python lib)
11 libjpeg:  http://www.ijg.org/
12 libpng:  http://www.libpng.org/pub/png/
13 zlib:   http://www.gzip.org/zlib/
14 ode:    http://q12.org/ode/ode.html
15 openal:  http://www.openal.org/home/            (for linux/windows)
16         sdl: http://www.libsdl.org/index.php (for openal)
17         smpeg: http://www.lokigames.com/development/smpeg.php3 (for openal)
18 fmod: http://www.fmod.org/
19
20 mozilla: http://www.mozilla.org/
21 nspr:  ftp://ftp.mozilla.org/pub/nspr/releases
22         (side note: on debian linux you will need mozilla-dev and libnspr-dev)
23
24 If you do not have GL you will also need mesa:
25 http://www.mesa3d.org
26
27 *********************************************************************
28 *********************************************************************
29 We are in the process of moving things over to automake/autoconf
30 The old makefiles are still in place and will work.  
31 If you want to get a working blender skip down to the next section 
32 and use this readme as a guide.
33
34 If you want to play with the new autoconf environment take a look at 
35 doc/autoconfig.txt
36
37 *********************************************************************
38 *********************************************************************
39
40 --Notes on compiling mxTextTools----------------------------------------------
41 To get the latest version to compile on my machine I had to
42 edit mxSetup.py and remove /usr/include from INCLPATH for it to build
43 properly.
44 (after doing this you need to edit blender/source/Makefile and
45 fix the pointer to it I'm still working on automating this)
46
47 --------------Basic Makefile TIPS---------------------------------------
48 Assuming you are using tcsh/csh do the following before compiling.
49 #Set this to wherever you have extracted the source.
50 setenv NANBLENDERHOME `pwd`
51 setenv MAKEFLAGS "-w -I$NANBLENDERHOME/source"
52
53 Or for bash/sh do this:
54 NANBLENDERHOME=`pwd`
55 export NANBLENDERHOME
56 MAKEFLAGS="-w -I$NANBLENDERHOME/source"
57 export MAKEFLAGS
58
59 Then edit source/nan_definitions.mk to fit you're environment.
60 (You'll want to change things like NAN_OPENSSL,NAN_JPEG, NAN_PNG etc.. 
61 to point to where you have it installed)
62
63 If you want to integrate the game-engine in Blender, you might want
64 to uncomment the following line in nan_compile.mk:
65 #CFLAGS += -DGAMEBLENDER=1
66 The define is disabled by default because there still are still some
67 problems with this at the moment.
68
69 If you tried to just have a go at making stuff you might wind up with
70 an empty file /tmp/.nanguess
71 You need to remove the empty file and it will get created automatically
72 by $NANBLENDERHOME/source/tools/guess/guessconfig after you have 
73 setup the NANBLENDERHOME variable.
74
75 After that cd $NANBLENDERHOME/intern 
76 make
77 make install
78
79 cd $NANBLENDERHOME/source/ode
80 Look at the README_BLENDER and follow instructions
81
82 Then cd $NANBLENDERHOME/source
83 make
84
85 If you have any problems with the above post a message to the Forums on
86 www.blender.org
87 ----------------------WINDOWS TIPS--------------------------------------
88 If you have any problems with the above post a message to the Forums on
89 www.blender.org
90
91
92 ----------------------Mac OSX TIPS--------------------------------------
93 When building Blender on OSX you have three choices:
94 METHOD 1. Build using the old NaN Makefiles.
95 METHOD 2. Build using the new automake/autoconf files
96 METHOD 3. Use the Project Builder project
97
98 METHOD 1 and 3
99 The first 4 steps are th same for methods 1 and 3. Only the actual Blender 
100 build step number 5 is different.
101
102 Step1:
103 If you want to follow method 1 and 3, follow the instructions above to set the
104 environment variables. You don't need to edit the Makefiles. They should work
105 out of the box in combinations with some external libraries that should be on
106 your system in a fixed location. 
107
108 Step 2:
109 You can use the package installer fink (http://fink.sourceforge.net/) for some
110 of the external libraries:
111 1. openssl (fink install openssl)
112 2. jpeg    (fink install jpeg)
113 3. png     (fink install png)
114
115 Step 3:
116 The rest of the external libraries are present in CVS in binary format so you
117 don't have to download them. Precompiled libraries are found in CVS in 
118 directory:
119 $NANBLENDERHOME/lib/darwin-6.1-powerpc
120 If you are not running on a darwing kernel 6.1 (which is likely if you auto-
121 update your system, you might want to add a symbolic link in the 
122 $NANBLENDERHOME/lib/ directory. For example, if you work on a 6.2 kernel:
123 ln -s darwin-6.1-powerpc darwin-6.2-powerpc
124
125 Step 4: 
126 Start the build process by building Blender's "intern" libraries. Navigate to 
127 $NANBLENDERHOME/intern and type make. This will build the intern libaries which
128 will be installed into the $NANBLENDERHOME/lib/darwin-6.1-powerpc (thanks to 
129 the symbolic link).
130 Now you can choose how to build Blender itself; using the Makefiles or the 
131 Project Builder project.
132
133 Step 5 METHOD 1:
134 Navigate to $NANBLENDERHOME/source and type make. 
135
136 Step 5 METHOD 3:
137 The project Builder project can be found in the directory:
138 $NANBLENDERHOME/projectfiles/pb_2_0_1
139 Start Project Builder open the blender.pbproj project, choose a target (blender
140 or player) and build.
141
142 Step 6:
143 Although the Makefiles in the intern directory run ranlib on the libraries 
144 built, the gcc linker complains about ranlib not being run. Until there is a
145 solution, you will need to run ranlib by hand once in a while when the make 
146 breaks. Luckily, the error message lists the full path of the file to run 
147 ranlib on... Anybody out there with a real solution? I guess the problem arises
148 from copying the files from one location to the other...
149
150
151 BUILDING EXTERNAL LIBRARIES
152 If you don't want to use the precompiled libraries you can download and/or
153 build them yourself. Here are some directions.
154
155 PYHON:
156 Mac OSX 10.2 (Jaguar) now comes with Python (2.2.1) pre-installed. This is fine
157 for producing the "frozen" Python code found in the intern directory. However,
158 the installation does not contain the python library to link against (at least
159 I could not find it). You could use fink to install Python but that Python 
160 installation depends on X being installed and that is a large installation.
161
162 If you prefer the easy way: download Python 2.2.2 from http://www.python.org.
163 Follow the instructions to in the documentation to install it on your box. If
164 you run OSX 10.2 it should install just fine. Basically a configure and a 
165 "make" will do the job. The result is a Python library that should be copied to
166 the library tree together with the associated header files.
167
168 Create the following  directories:
169 $NANBLENDERHOME/lib/darwin-6.1-powerpc/python/include/python2.2
170 $NANBLENDERHOME/lib/darwin-6.1-powerpc/python/lib/python2.2/config
171 Now copy the include files and the libpython2.2.a library to those locations.
172
173 FMOD:
174 Download FMOD from http://www.fmod.org/ and unpack with StuffIt Expander. The
175 archive contains header files and a library. Copy those to these directories
176 (that you need to create first):
177 $NANBLENDERHOME/lib/darwin-6.1-powerpc/fmod/include
178 $NANBLENDERHOME/lib/darwin-6.1-powerpc/fmod/lib
179
180 ODE:
181 Ode is currently included in the source tree of Blender. This might change in
182 the close future. But for now you don't need to download Ode.
183 If you want to build ODE yourself, you'll have to edit a config file of ODE first.
184 go to $NANBLENDERHOME/source/ode/config and edit the file "user-settings" so 
185 that platform is equal to osx (PLATFORM=osx).
186
187 Success!