patch [#26063] Fix deb package versioning (Patch for #26062)
[blender.git] / build_files / package_spec / debian / rules
index 5844d289d884f0239696a9669ae23a527c63c6c9..60b8c694dd4303fc98d45d5a88b86e4a62bbcefd 100755 (executable)
@@ -18,6 +18,12 @@ override_dh_auto_configure:
                -DWITH_PYTHON_INSTALL:BOOL=OFF \
                -DWITH_OPENCOLLADA:BOOL=OFF
 
+override_dh_install:
+       dh_install
+
+       # remove duplicated docs
+       rm -rf debian/blender-snapshot/usr/share/doc/blender
+
 override_dh_python3:
        dh_python3 -V 3.1-3.2 /usr/share/blender/$(REL)/scripts
 
@@ -27,4 +33,4 @@ get-orig-source:
        svn -q export -r $(REV) $(SVN_URL) get-orig-source/blender-$(VER)
        GZIP='--best --no-name' tar czf $(TARBALL) -C get-orig-source blender-$(VER)
        rm -rf get-orig-source
-       echo "  "$(TARBALL)" created; move it to the right destination to build the package"
+       @echo "$(TARBALL) created; move it to the right destination to build the package"