Buildbot: fix for missing CUDA compute after recent changes
[blender.git] / build_files / buildbot / config / user-config-glibc211-i686.py
index 2b1af3567733e0a0f162adeef3699774a08e2e64..8274236a37dc97d4192550b59ff5db9f0d49954a 100644 (file)
@@ -1,6 +1,7 @@
 BF_BUILDDIR = '../blender-build/linux-glibc211-i686'
 BF_INSTALLDIR = '../blender-install/linux-glibc211-i686'
 BF_BUILDDIR = '../blender-build/linux-glibc211-i686'
 BF_INSTALLDIR = '../blender-install/linux-glibc211-i686'
-BF_NUMJOBS = 2
+BF_NUMJOBS = 4
+WITHOUT_BF_OVERWRITE_INSTALL = True
 
 # Python configuration
 BF_PYTHON_VERSION = '3.3'
 
 # Python configuration
 BF_PYTHON_VERSION = '3.3'
@@ -103,15 +104,14 @@ WITH_BF_FFTW3 = True
 WITH_BF_STATICFFTW3 = True
 
 # JACK
 WITH_BF_STATICFFTW3 = True
 
 # JACK
-WITH_BF_JACK = True
+WITH_BF_JACK = False
 WITH_BF_STATICJACK = True
 BF_JACK_LIB_STATIC = '${BF_ZLIB}/lib/libjack.a'
 
 # Cycles
 WITH_BF_CYCLES = True
 WITH_BF_CYCLES_CUDA_BINARIES = True
 WITH_BF_STATICJACK = True
 BF_JACK_LIB_STATIC = '${BF_ZLIB}/lib/libjack.a'
 
 # Cycles
 WITH_BF_CYCLES = True
 WITH_BF_CYCLES_CUDA_BINARIES = True
-#BF_CYCLES_CUDA_BINARIES_ARCH = ['sm_13', 'sm_20', 'sm_21', 'sm_30']
-BF_CYCLES_CUDA_BINARIES_ARCH = ['sm_20', 'sm_21', 'sm_30']
+BF_CYCLES_CUDA_BINARIES_ARCH = []
 
 WITH_BF_OIIO = True
 WITH_BF_STATICOIIO = True
 
 WITH_BF_OIIO = True
 WITH_BF_STATICOIIO = True
@@ -160,6 +160,6 @@ WITH_BF_OCEANSIM = True
 
 # Compilation and optimization
 BF_DEBUG = False
 
 # Compilation and optimization
 BF_DEBUG = False
-REL_CCFLAGS = ['-O2', '-msse', '-msse2']  # C & C++
+REL_CCFLAGS = ['-DNDEBUG', '-O2', '-msse', '-msse2']  # C & C++
 PLATFORM_LINKFLAGS = ['-lrt']
 PLATFORM_LINKFLAGS = ['-lrt']
-BF_PROGRAM_LINKFLAGS = ['-Wl,--whole-archive', '-loslexec', '-Wl,--no-whole-archive']
+BF_PROGRAM_LINKFLAGS = ['-Wl,--whole-archive', '-loslexec', '-Wl,--no-whole-archive', '-Wl,--version-script=source/creator/blender.map']