i18n: fake_gettext is no longer needed for python
[blender.git] / build_files / cmake / cmake_static_check_cppcheck.py
index 4249537eca8fcbe73aca427139f7efbd13131549..f6d46904794059b94ddf9a5760043da10a816c14 100644 (file)
@@ -1,6 +1,6 @@
 #!/usr/bin/env python
 
 #!/usr/bin/env python
 
-# $Id:
+# $Id$
 # ***** BEGIN GPL LICENSE BLOCK *****
 #
 # This program is free software; you can redistribute it and/or
 # ***** BEGIN GPL LICENSE BLOCK *****
 #
 # This program is free software; you can redistribute it and/or
@@ -36,7 +36,9 @@ CHECKER_IGNORE_PREFIX = [
 CHECKER_BIN = "cppcheck"
 
 CHECKER_ARGS = [
 CHECKER_BIN = "cppcheck"
 
 CHECKER_ARGS = [
-    "-I" + os.join(project_source_info.SORCE_DIR, "blender/extern/glew/include"),
+    # not sure why this is needed, but it is.
+    "-I" + os.path.join(project_source_info.SOURCE_DIR, "extern/glew/include"),
+
     #  "--check-config", # when includes are missing
     #  "--enable=all",  # if you want sixty hundred pedantic suggestions
     ]
     #  "--check-config", # when includes are missing
     #  "--enable=all",  # if you want sixty hundred pedantic suggestions
     ]