2.5
[blender.git] / README
diff --git a/README b/README
index 4ef9f9e475ed64454bc350bca8cc41e00f9f8017..1a7964f954e4a2366d58e8295aefff6f92786cfd 100644 (file)
--- a/README
+++ b/README
-Welcome to the fun world of open-source.
-
-This file is to help you get started using the source and will hopefully
-answer most questions.
-
-Here are some links to external packages you may or maynot need:
-
-openssl:  http://www.openssl.org
-python:  http://www.python.org
-mxtexttools:http://www.egenix.com/files/python/mxTextTools.html (python lib)
-libjpeg:  http://www.ijg.org/
-libpng:  http://www.libpng.org/pub/png/
-zlib:   http://www.gzip.org/zlib/
-openal:  http://www.openal.org/home/           (for linux/windows)
-       sdl: http://www.libsdl.org/index.php (for openal)
-       smpeg: http://www.lokigames.com/development/smpeg.php3 (for openal)
-fmod: http://www.fmod.org/
-
-mozilla: http://www.mozilla.org/
-nspr:  ftp://ftp.mozilla.org/pub/nspr/releases
-       (side note: on debian linux you will need mozilla-dev and libnspr-dev)
-
-If you do not have GL you will also need mesa:
-http://www.mesa3d.org
-
-*********************************************************************
-*********************************************************************
-We are in the process of moving things over to automake/autoconf
-The old makefiles are still in place and will work.  If you want to
-get a working blender skip down to the next section and use this readme as
-a guide.
-
-If you want to play with the new autoconf environment you need to do the 
-following, inside this dir:
-./bootstrap
-mkdir ../newdir
-cd ../newdir
-../blender/configure
-
-Take a look at INSTALL for options you can give to configure.
-About half of the intern directory is done so you won't get very far.
-If you want to work on fixing it you need to edit Makefile.am's and 
-configure.ac
-after editing those files you need to run bootstrap again.
-
-TODO to finish up the intern dir
-Square away how ghost works.
-(i.e. would be nice if under windows you could choose X11 or normal windows
-libs, same with macos.. right now its a cludge and it doesn't do one explicitly
-probably involves changing the way configure.ac picks stuff)
-
-Get intern/python figured out.
-
-Add the following to configure.ac
-       --with-openssl=dir
-       --with-mozilla=dir      (get it so nspr is autodetected here)
-       --with-nspr=dir         (incase in different dir)
-       --with-jpeg=dir
-       --with-png=dir
-       --with-zlib=dir
-
-*********************************************************************
-*********************************************************************
-
---Notes on compiling mxTextTools----------------------------------------------
-To get the latest version to compile on my machine I had to
-edit mxSetup.py and remove /usr/include from INCLPATH for it to build
-properly.
-(after doing this you need to edit blender/source/Makefile and
-fix the pointer to it I'm still working on automating this)
-
---------------Basic Makefile TIPS---------------------------------------
-Assuming you are using tcsh/csh do the following before compiling.
-#Set this to wherever you have extracted the source.
-setenv NANBLENDERHOME `pwd`
-setenv MAKEFLAGS "-w -I$NANBLENDERHOME/source"
-
-Or for bash/sh do this:
-NANBLENDERHOME=`pwd`
-export NANBLENDERHOME
-MAKEFLAGS="-w -I$NANBLENDERHOME/source"
-export MAKEFLAGS
-
-Then edit source/nan_definitions.mk to fit you're environment.
-(You'll want to change things like NAN_OPENSSL,NAN_JPEG, NAN_PNG etc.. 
-to point to where you have it installed)
-
-If you tried to just have a go at making stuff you might wind up with
-an empty file /tmp/.nanguess
-You need to remove the empty file and it will get created automatically
-by $NANBLENDERHOME/source/tools/guess/guessconfig after you have 
-setup the NANBLENDERHOME variable.
-
-After that cd $NANBLENDERHOME/intern 
-make
-make install
-
-cd $NANBLENDERHOME/source/ode
-Look at the README_BLENDER and follow instructions
-
-Then cd $NANBLENDERHOME/source
-make
-
-If you have any problems with the above post a message to the Forums on
-www.blender.org
-----------------------WINDOWS TIPS--------------------------------------
-If you have any problems with the above post a message to the Forums on
-www.blender.org
-
-
-----------------------Mac OSX TIPS--------------------------------------
-Now before you go to the source directory, make sure you have installed the
-external libraries that Blender depends upon. Here is a description of the 
-things you need.
-
-FINK:
-Use fink (http://fink.sourceforge.net/) to install the following libraries that
-Blender depends on:
-1. openssl (fink install openssl)
-2. jpeg    (fink install jpeg)
-3. png     (fink install png)
-
-PYTHON:
-Mac OSX 10.2 (Jaguar) now comes with Python (2.2.1) pre-installed. This is fine
-for producing the "frozen" Python code found in the intern directory. However,
-the installation does not contain the python library to link against (at least
-I could not find it). You could use fink to install Python but that Python 
-installation depends on X being installed and that is a large installation.
-
-If you prefer the easy way: download Python 2.2.2 from http://www.python.org.
-Follow the instructions to in the documentation to install it on your box. If
-you run OSX 10.2 it should install just fine. Basically a configure and a 
-"make" will do the job. The result is a Python library that should be copied to
-the library tree together with the associated header files.
-
-Create the following  directories:
-$NANBLENDERHOME/lib/darwin-6.1-powerpc/python/include/python2.2
-$NANBLENDERHOME/lib/darwin-6.1-powerpc/python/lib/python2.2/config
-Now copy the include files and the libpython2.2.a library to those locations.
-
-FMOD:
-Download FMOD from http://www.fmod.org/ and unpack with StuffIt Expander. The
-archive contains header files and a library. Copy those to these directories
-(that you need to create first):
-$NANBLENDERHOME/lib/darwin-6.1-powerpc/fmod/include
-$NANBLENDERHOME/lib/darwin-6.1-powerpc/fmod/lib
-
-RANLIB:
-Although the make files run ranlib on the libraries built, the gcc linker 
-complains about ranlib not being run. Until there is a solution, you will need
-to run ranlib by hand once in a while when the make breaks. Luckily, the error
-message lists the full path of the file to run ranlib on... Anybody out there 
-with a real solution? I guess the problem arises from copying the files from 
-one location to the other...
-
-Now wait, don't type make yet! You'll have to edit a config file of ODE first.
-go to $NANBLENDERHOME/source/ode/config and edit the file "user-settings" so 
-that platform is equal to osx (PLATFORM=osx).
-
-Success!
+Welcome to the fun world of open source.
+
+For instructions on building and installing Blender, please see the file named
+INSTALL.
+
+
+---------------------.Blanguages and the .blender directory---------------------
+
+The .blender directory holds various data files for Blender.
+In the 2.28a release those are the .Blanguages file containing a list of
+translations, the translations themselves and a default ttf font.
+
+Blender checks for the presence of this directory in several locations:
+       - the current directory
+       - your home directory
+       - On OSX, the blender bundle is also checked 
+       - On Windows, the installation dir is checked.
+
+If you get a 'File ".Blanguages" not found' warning, try to copy the .blender
+dir to one of these locations (your home directory being recommended).
+
+
+
+-------------------------------------Links--------------------------------------
+
+Getting Involved:
+http://www.blender.org/community/get-involved
+
+Community:
+http://www.blender.org/Community
+
+Main blender development site:
+http://www.blender.org
+
+The Blender project homepage:
+http://projects.blender.org/projects/bf-blender
+
+Documentation:
+http://www.blender.org/education-help
+
+Bug tracker:
+http://www.blender.org/development/report-a-bug
+
+Feature request tracker:
+http://wiki.blender.org/index.php/Requests