Fix build with old CMake versions.
[blender.git] / intern / cycles / kernel / CMakeLists.txt
index 73ff7aeda154a5a7fcfac194ef6830121c8f6f4e..78e03a7f066bf4aaace4e67e65cf9ce99be4f802 100644 (file)
@@ -454,7 +454,7 @@ if(WITH_CYCLES_CUDA_BINARIES)
        foreach(arch ${CYCLES_CUDA_BINARIES_ARCH})
                if(${arch} MATCHES "sm_2.")
                        message(STATUS "CUDA binaries for ${arch} are no longer supported, skipped.")
-               elseif(${arch} MATCHES "sm_7." AND NOT (${CUDA_VERSION} VERSION_GREATER_EQUAL 10.0))
+               elseif(${arch} MATCHES "sm_7." AND (${CUDA_VERSION} VERSION_LESS 10.0))
                        message(STATUS "CUDA binaries for ${arch} require CUDA 10.0+, skipped.")
                else()
                        # Compile regular kernel