remove python2.x support
[blender.git] / source / gameengine / GameLogic / SCA_ORController.cpp
index a526dd8353cdf43de319be8758567a44a5ef6763..12e2f610986c10bc70b0ea508872d9f100abd1f1 100644 (file)
@@ -93,13 +93,7 @@ void SCA_ORController::Trigger(SCA_LogicManager* logicmgr)
 
 /* Integration hooks ------------------------------------------------------- */
 PyTypeObject SCA_ORController::Type = {
-#if (PY_VERSION_HEX >= 0x02060000)
        PyVarObject_HEAD_INIT(NULL, 0)
-#else
-       /* python 2.5 and below */
-       PyObject_HEAD_INIT( NULL )  /* required py macro */
-       0,                          /* ob_size */
-#endif
        "SCA_ORController",
        sizeof(PyObjectPlus_Proxy),
        0,