- add -lXi to prevent "undefined reference to `XGetExtensionVersion'..."
[blender.git] / source / nan_link.mk
index 9314f2d708f1733f82ad3525e15308676d9c137d..9b21ebfe2db93e4d0c389ff7a590caeabc385014 100644 (file)
@@ -69,16 +69,10 @@ ifeq ($(OS),darwin)
 endif
 
 ifeq ($(OS),freebsd)
-    LLIBS = -L/usr/X11R6/lib -lX11 -lXmu -lm -lutil -lz -pthread -lc_r
+    LLIBS = -L/usr/X11R6/lib -lX11 -lXmu -lXi -lm -lutil -lz -pthread -lc_r
     DADD = -lGL -lGLU
     DYNLDFLAGS = -shared $(LDFLAGS)
     LOPTS = -Wl,--export-dynamic
-  ifeq ($(OS_VERSION),$(findstring $(OS_VERSION), "3.4 4.0"))
-    COMMENT = "MESA 3.0"
-    SADD = /usr/X11R6/lib/libGL.a /usr/X11R6/lib/libGLU.a
-    LLIBS += -lc
-  else
-  endif
 endif
 
 ifeq ($(OS),irix)