default to Python3.3 on Linux for SCons and CMake, warn when building with python...
authorCampbell Barton <ideasman42@gmail.com>
Mon, 5 Nov 2012 13:48:42 +0000 (13:48 +0000)
committerCampbell Barton <ideasman42@gmail.com>
Mon, 5 Nov 2012 13:48:42 +0000 (13:48 +0000)
commit004f8d78eded92e1cd6f1eeade27873c4aa2de76
tree210b2f26060bc809740ebeaad543180a5b0af064
parent6ee3bf5300cb345a02563a4137c8b0e651b2a564
default to Python3.3 on Linux for SCons and CMake, warn when building with python 3.2x or older.

also remove casts to keep Python3.2 warning quiet.
build_files/cmake/Modules/FindPythonLibsUnix.cmake
build_files/scons/config/Modules/FindPython.py
source/blender/python/generic/bgl.c
source/blender/python/generic/idprop_py_api.c
source/blender/python/intern/bpy_rna.c
source/blender/python/intern/bpy_util.h
source/blender/python/mathutils/mathutils_Color.c
source/blender/python/mathutils/mathutils_Euler.c
source/blender/python/mathutils/mathutils_Matrix.c
source/blender/python/mathutils/mathutils_Quaternion.c
source/blender/python/mathutils/mathutils_Vector.c