Bring back support of FFmpeg >= 0.7
authorSergey Sharybin <sergey.vfx@gmail.com>
Fri, 19 Apr 2013 17:23:08 +0000 (17:23 +0000)
committerSergey Sharybin <sergey.vfx@gmail.com>
Fri, 19 Apr 2013 17:23:08 +0000 (17:23 +0000)
commit349b71fd02354a3d1288bccbb2d984d5f9a7e605
treea54f8a5f9cefafd11d8191f1fa658a5b300a3f55
parentfba67abf7a9caf8ccfa03af38d91f70de8875d2d
Bring back support of FFmpeg >= 0.7

After planar codecs support minimal FFmpeg was
bumped to 0.10 which was not so much nice because
it was only released only later last year.

Didn't find a way to make compatibility code local
in ffmpeg_compat, so there're some ifdefs in
audaspace and writeffmpeg.

Not entirely happy, but having a bit of ifdefs in
code better than lots of real PITA for platform
maintainers.
intern/audaspace/ffmpeg/AUD_FFMPEGReader.cpp
intern/ffmpeg/ffmpeg_compat.h
source/blender/blenkernel/intern/writeffmpeg.c