Cycles: upgrade to CUDA 10.1 as the one officially supported version.
authorBrecht Van Lommel <brechtvanlommel@gmail.com>
Fri, 15 Mar 2019 13:18:22 +0000 (14:18 +0100)
committerBrecht Van Lommel <brechtvanlommel@gmail.com>
Fri, 15 Mar 2019 15:52:28 +0000 (16:52 +0100)
commit65d95879f73951861a90efe1c3ac5d1d03530fd6
tree33f40dfe8010f056b1073b305be4c9eca09d4781
parent56a8c2a3203482f0fc7437b0cefe2160e27f7fe3
Cycles: upgrade to CUDA 10.1 as the one officially supported version.

This version fixes various bugs, and there is no need anymore to use both
9.1 and 10.0 for different cards.

There is a bug related to WITH_CYCLES_CUBIN_COMPILER and bump mapping in the
regression tests, so that remains disabled same as it was for CUDA 10.0.

Fix T59286: CUDA bake failing on some cards.
Fix T56858: CUDA 9.2 and 10 issues.
build_files/buildbot/slave_compile.py
build_files/cmake/config/blender_release.cmake
intern/cycles/CMakeLists.txt
intern/cycles/device/device_cuda.cpp
intern/cycles/kernel/CMakeLists.txt