build_environment: support for msvc2017 and newer cmake.
authorRay Molenkamp <github@lazydodo.com>
Sat, 2 Jun 2018 19:59:56 +0000 (13:59 -0600)
committerRay Molenkamp <github@lazydodo.com>
Sat, 2 Jun 2018 19:59:56 +0000 (13:59 -0600)
commit815b1f24fa298784d9204b9248bc69ceb2b3d762
tree588894743c41097540b3ac2d11b0338474b30024
parent2ef695fabf33e227d742aa5adf39490a2a87f58b
build_environment: support for msvc2017 and newer cmake.

-expanded build_deps.cmd with 2017 support, it can't locate msvc2017 so needs to be run from developer prompt.
-Newer cmake was unhappy with openal's cmakelists.txt
-collada has warning as error on and errored out on new msvc2017 warnings.
build_files/build_environment/cmake/openal.cmake
build_files/build_environment/cmake/options.cmake
build_files/build_environment/patches/openal.diff [new file with mode: 0644]
build_files/build_environment/windows/build_deps.cmd