Fix #25649: Image editor paint icon missing until enter weight paint
authorSergey Sharybin <sergey.vfx@gmail.com>
Fri, 17 Feb 2012 16:06:32 +0000 (16:06 +0000)
committerSergey Sharybin <sergey.vfx@gmail.com>
Fri, 17 Feb 2012 16:06:32 +0000 (16:06 +0000)
commit8f97f3ed2961dcd03ca3d5aeb314cfdf2d0dc58e
tree9e46e337d60016a49cc8e92acfa94a4c59f6b282
parent17f6f7e2af6d725522176d9c665cd220ede3e6ca
Fix #25649: Image editor paint icon missing until enter weight paint

Issue was caused by starting Icon Preview render job from two places:
- Texture buttons for small icon preview
- Properties panel in image editor for large icon of texture

This preview job is starting in suspended mode and if new instance of the same job is
starting, suspended job will be totally stopped. This is normally for cases when you're
changing different settings -- in this case you'd wouldn't want re-render be triggered
on every slide change.
But what we've have with brush preview is that two instances of this job were creating for
large and small icon separately, but because of described policy only one icon was rendered.

If suspended job is getting to be stopped, check if it was started for the same icon
resolution and if not, that resolution will be also rendered in new job.
So it'll be still minimal re-rendering happens, but in cases when job was started from
two places for different icon sizes it'll work just fine.
source/blender/editors/interface/interface_icons.c
source/blender/editors/interface/interface_layout.c
source/blender/editors/interface/interface_templates.c
source/blender/editors/render/render_preview.c
source/blender/editors/space_image/space_image.c
source/blender/editors/space_view3d/space_view3d.c