BGE: Remove old world bge.render API
authorThomas Szepe <HG1_public@gmx.net>
Mon, 23 Mar 2015 23:27:45 +0000 (00:27 +0100)
committerThomas Szepe <HG1_public@gmx.net>
Mon, 23 Mar 2015 23:27:45 +0000 (00:27 +0100)
commitee579684617c1a9868b2c75cfb5d32efe26c1198
treec09620e5c90a67a4ad7aa4ed5c71ad906418d86b
parentfd22a92939dc937216f50d1350a63de872e0a6be
BGE: Remove old world bge.render API

This patch can be used to remove the old world bge.render API if the new world API D157 is used.

If  the new world API is applied we can remove the old API because the old has newer worked.
The patch keep the two old working methods for backward compatibility.

Reviewers: campbellbarton, moguri

Reviewed By: campbellbarton, moguri

Subscribers: brecht

Differential Revision: https://developer.blender.org/D158
doc/python_api/rst/bge.render.rst
source/gameengine/Ketsji/KX_PythonInit.cpp
source/gameengine/Ketsji/KX_WorldInfo.cpp
source/gameengine/Ketsji/KX_WorldInfo.h