missed setting WITH_BUILTIN_GLEW on non *nux OS's
authorCampbell Barton <ideasman42@gmail.com>
Wed, 6 Apr 2011 01:51:43 +0000 (01:51 +0000)
committerCampbell Barton <ideasman42@gmail.com>
Wed, 6 Apr 2011 01:51:43 +0000 (01:51 +0000)
also made WITH_PYTHON advanced.

CMakeLists.txt

index 11831ef..ef8b8ef 100644 (file)
@@ -72,6 +72,7 @@ get_blender_version()
 # Blender internal features
 option(WITH_INTERNATIONAL "Enable I18N (International fonts and text)" ON)
 option(WITH_PYTHON        "Enable Embedded Python API  (only disable for development)" ON)
+mark_as_advanced(WITH_PYTHON)  # dont want people disabling this unless they really know what they are doing.
 option(WITH_PYTHON_SAFETY "Enable internal API error checking to track invalid data to prevent crash on access (at the expense of some effeciency, only enable for development)." OFF)
 option(WITH_PYTHON_MODULE "Enable building as a python module (experemental, only enable for development)" OFF)
 option(WITH_BUILDINFO     "Include extra build details (only disable for development & faster builds)" ON)
@@ -90,6 +91,9 @@ endif()
 if(UNIX AND NOT APPLE)
        option(WITH_X11_XINPUT "Enable X11 Xinput (tablet support)"     ON)
        option(WITH_BUILTIN_GLEW "Use GLEW OpenGL wrapper library bundled with blender" ON)
+else()
+       # not an option for other OS's
+       set(WITH_BUILTIN_GLEW ON)
 endif()
 
 # Modifiers