macOS: use python version 3.6 when building blender
authorArto Kitula <arto.kitula@gmail.com>
Tue, 19 Sep 2017 21:07:56 +0000 (00:07 +0300)
committerArto Kitula <arto.kitula@gmail.com>
Tue, 19 Sep 2017 21:07:56 +0000 (00:07 +0300)
build_files/cmake/platform/platform_apple.cmake

index 00c5772e11c59e9ed254816031ff4903ecd78111..b4e99865af018b9afd41b78d6b90c218cd5a9c30 100644 (file)
@@ -88,7 +88,7 @@ endif()
 
 if(WITH_PYTHON)
        # we use precompiled libraries for py 3.5 and up by default
-       set(PYTHON_VERSION 3.5)
+       set(PYTHON_VERSION 3.6)
        if(NOT WITH_PYTHON_MODULE AND NOT WITH_PYTHON_FRAMEWORK)
                # normally cached but not since we include them with blender
                set(PYTHON_INCLUDE_DIR "${LIBDIR}/python/include/python${PYTHON_VERSION}m")