Fix #26062: build_debian.sh gives unappropriate deb version
authorSergey Sharybin <sergey.vfx@gmail.com>
Sun, 13 Feb 2011 19:47:57 +0000 (19:47 +0000)
committerSergey Sharybin <sergey.vfx@gmail.com>
Sun, 13 Feb 2011 19:47:57 +0000 (19:47 +0000)
Added subverison number to debian package version. Quick tests run ok,
but haven't checked if deb version comparation also goes fine.

build_files/package_spec/build_debian.sh

index 17c0abb888b6b6915c0e82d6fb62132eefcde5ef..8ebcde99ef2301c0f87d83908b38f47837e533af 100755 (executable)
@@ -15,7 +15,8 @@ BLENDER_REVISION=$(svnversion)
 
 blender_srcdir=$PWD
 blender_version=$(grep BLENDER_VERSION $blender_srcdir/source/blender/blenkernel/BKE_blender.h | tr -dc 0-9)
-BLENDER_VERSION=$(expr $blender_version / 100).$(expr $blender_version % 100)
+blender_subversion=$(grep BLENDER_SUBVERSION $blender_srcdir/source/blender/blenkernel/BKE_blender.h | tr -dc 0-9)
+BLENDER_VERSION=$(expr $blender_version / 100).$(expr $blender_version % 100).${blender_subversion}
 DEB_VERSION=${BLENDER_VERSION}+svn${BLENDER_REVISION}-bf
 
 # update debian/changelog