Cycles: Only use CUDA 8.0 as officially supported one
authorSergey Sharybin <sergey.vfx@gmail.com>
Wed, 29 Mar 2017 13:06:47 +0000 (15:06 +0200)
committerSergey Sharybin <sergey.vfx@gmail.com>
Wed, 29 Mar 2017 13:06:47 +0000 (15:06 +0200)
This deprecates CUDA 7.5.

intern/cycles/device/device_cuda.cpp

index 0927c15a85089b486c81b2ef003dd1b2da00a290..ba3ca3c3e1e553e5c08879d77fc177ae6f287af5 100644 (file)
@@ -345,15 +345,15 @@ public:
                        cuda_error_message("CUDA nvcc compiler version could not be parsed.");
                        return false;
                }
-               if(cuda_version < 75) {
+               if(cuda_version < 80) {
                        printf("Unsupported CUDA version %d.%d detected, "
-                              "you need CUDA 7.5 or newer.\n",
+                              "you need CUDA 8.0 or newer.\n",
                               major, minor);
                        return false;
                }
-               else if(cuda_version != 75 && cuda_version != 80) {
+               else if(cuda_version != 80) {
                        printf("CUDA version %d.%d detected, build may succeed but only "
-                              "CUDA 7.5 and 8.0 are officially supported.\n",
+                              "CUDA 8.0 is officially supported.\n",
                               major, minor);
                }
                return true;