add some comments about libalut and a BF_OPENAL_LIB line
authorStephen Swaney <sswaney@centurytel.net>
Mon, 26 Feb 2007 20:50:50 +0000 (20:50 +0000)
committerStephen Swaney <sswaney@centurytel.net>
Mon, 26 Feb 2007 20:50:50 +0000 (20:50 +0000)
to uncomment if necessary.

libalut is becoming problematic.  some distros have it, some do not.
At least one considers it deprecated, iirc.

config/linux2-config.py

index 5e7dcfa7297c528a052a195f79cce535561a6c8b..4d4703bf41fdaf55f2aac0e071403d944e50af6b 100644 (file)
@@ -15,6 +15,9 @@ WITH_BF_OPENAL = 'true'
 BF_OPENAL = '/usr'
 BF_OPENAL_INC = '${BF_OPENAL}/include'
 BF_OPENAL_LIB = 'openal'
+# some distros have a separate libalut
+# if you get linker complaints, you need to uncomment the line below
+# BF_OPENAL_LIB = 'openal alut'  
 
 WITH_BF_SDL = 'true'
 BF_SDL = '/usr' #$(shell sdl-config --prefix)