CMake: New dependency graph requires either Boost or C++11
authorSergey Sharybin <sergey.vfx@gmail.com>
Fri, 19 Feb 2016 09:18:38 +0000 (10:18 +0100)
committerSergey Sharybin <sergey.vfx@gmail.com>
Fri, 19 Feb 2016 09:18:59 +0000 (10:18 +0100)
CMakeLists.txt

index 4e623d587bc2a332789aefdfc736fc164d3bf7bf..1603f1f98b2b070a53291b2fab4ceb76b0abf582 100644 (file)
@@ -673,8 +673,11 @@ if(NOT WITH_BOOST)
 elseif(WITH_CYCLES OR WITH_OPENIMAGEIO OR WITH_AUDASPACE OR WITH_INTERNATIONAL OR WITH_OPENVDB OR WITH_OPENCOLORIO OR WITH_MOD_BOOLEAN)
        # Keep enabled
 else()
-       # Enabled but we don't need it
-       set(WITH_BOOST OFF)
+       # New dependency graph needs either Boost or C++11 for function bindings.
+       if(NOT USE_CPP11)
+               # Enabled but we don't need it
+               set(WITH_BOOST OFF)
+       endif()
 endif()
 
 # auto enable openimageio for cycles