set required MacOS version to 10.9
authorMike Erwin <significant.bit@gmail.com>
Thu, 16 Mar 2017 19:02:07 +0000 (15:02 -0400)
committerMike Erwin <significant.bit@gmail.com>
Thu, 16 Mar 2017 19:02:55 +0000 (15:02 -0400)
We could do more to simplify build files, but this is a start.

build_files/cmake/platform/platform_apple.cmake
release/darwin/blender.app/Contents/Info.plist

index 04485e3..f2a6aee 100644 (file)
@@ -23,6 +23,8 @@
 
 # Libraries configuration for Apple.
 
+set(MACOSX_DEPLOYMENT_TARGET "10.9")
+
 if(NOT DEFINED LIBDIR)
        if(WITH_CXX11)
                set(LIBDIR ${CMAKE_SOURCE_DIR}/../lib/darwin)
index 36cb5d2..92e8d8c 100644 (file)
@@ -3,7 +3,7 @@
 <plist version="1.0">
 <dict>
        <key>LSMinimumSystemVersion</key>
-       <string>10.7.0</string>
+       <string>10.9.0</string>
        <key>CFBundleDocumentTypes</key>
        <array>
                <dict>