QTkit : update build checks to allow only 10.5+/64bit builds
authorDamien Plisson <damien.plisson@yahoo.fr>
Thu, 3 Dec 2009 09:59:52 +0000 (09:59 +0000)
committerDamien Plisson <damien.plisson@yahoo.fr>
Thu, 3 Dec 2009 09:59:52 +0000 (09:59 +0000)
Other SDK versions do not handle correctly QTKit movie creation in a background thread.
Carbon quicktime should be used for the 32bit builds (USE_QTKIT = 0)

source/blender/quicktime/apple/qtkit_export.m

index 59cd669d738dac1edce8a2796a1f43f471856bba..c7759055d7e271213d82f2402cc7251d60149fe6 100644 (file)
@@ -57,8 +57,8 @@
 #import <Cocoa/Cocoa.h>
 #import <QTKit/QTKit.h>
 
-#if MAC_OS_X_VERSION_MIN_REQUIRED <= MAC_OS_X_VERSION_10_4
-#error OSX 10.5 minimum is needed for QTKit
+#if (MAC_OS_X_VERSION_MIN_REQUIRED <= MAC_OS_X_VERSION_10_4) || !__LP64__
+#error 64 bit build & OSX 10.5 minimum are needed for QTKit
 #endif
 
 #include "quicktime_import.h"