skip BLI_STATIC_ASSERT for Coverity builds (caused parse error)
authorCampbell Barton <ideasman42@gmail.com>
Sat, 3 Aug 2013 13:08:51 +0000 (13:08 +0000)
committerCampbell Barton <ideasman42@gmail.com>
Sat, 3 Aug 2013 13:08:51 +0000 (13:08 +0000)
source/blender/blenlib/BLI_utildefines.h

index 4d80080ed86e308c29b0916197cc3c02e4a48c4c..63235ad9c82ba16c4a13149069fd064fdff5f7c6 100644 (file)
 #  define BLI_assert(a) (void)0
 #endif
 
-/* C++ can't use _Static_assert, expects static_assert() but c++0x only */
-#if (!defined(__cplusplus)) && (defined(__GNUC__) && ((__GNUC__ * 100 + __GNUC_MINOR__) >= 406))  /* gcc4.6+ only */
+/* C++ can't use _Static_assert, expects static_assert() but c++0x only,
+ * Coverity also errors out. */
+#if (!defined(__cplusplus)) && \
+    (!defined(__COVERITY__)) && \
+    (defined(__GNUC__) && ((__GNUC__ * 100 + __GNUC_MINOR__) >= 406))  /* gcc4.6+ only */
 #  define BLI_STATIC_ASSERT(a, msg) _Static_assert(a, msg);
 #else
    /* TODO msvc, clang */