change default for darwin for better compatibility with gcc4.0
authorJean-Luc Peurière <jlp@nerim.net>
Sat, 3 May 2008 17:04:28 +0000 (17:04 +0000)
committerJean-Luc Peurière <jlp@nerim.net>
Sat, 3 May 2008 17:04:28 +0000 (17:04 +0000)
config/darwin-config.py

index 8fec38ac48ebdeff44d7b07a0e137c1730e00325..8fd6c3251ba64b46be82667cea44b90c0ac87f93 100644 (file)
@@ -221,9 +221,10 @@ if USE_SDK=='true':
        CCFLAGS=SDK_FLAGS+CCFLAGS
        CXXFLAGS=SDK_FLAGS+CXXFLAGS
        
+# you can add -mssse3 if gcc >= 4.2
 if MAC_PROC == 'i386':
-       REL_CFLAGS = ['-O2','-ftree-vectorize','-msse','-msse2','-msse3','-mssse3']
-       REL_CCFLAGS = ['-O2','-ftree-vectorize','-msse','-msse2','-msse3','-mssse3']
+       REL_CFLAGS = ['-O2','-ftree-vectorize','-msse','-msse2','-msse3']
+       REL_CCFLAGS = ['-O2','-ftree-vectorize','-msse','-msse2','-msse3']
 else:
        CFLAGS = CFLAGS+['-fno-strict-aliasing']
        CCFLAGS =  CCFLAGS+['-fno-strict-aliasing']