blender.git
15 years agoThree fixes in edge/crease edit for Transform Properties Panel (NKEY)
Ton Roosendaal [Thu, 9 Dec 2004 16:43:37 +0000 (16:43 +0000)]
Three fixes in edge/crease edit for Transform Properties Panel (NKEY)

- code wasn't edge-select aware yet
- the "Median" button now allows to move a "median" correctly around, also
  to 0 or 1 in a single step
- missing undo push  here.

15 years agoBug fix #1995
Ton Roosendaal [Thu, 9 Dec 2004 13:46:38 +0000 (13:46 +0000)]
Bug fix #1995

Unpacking a file with packed sounds didn't save the samples... was due
to *very* weird method samples were put in Blender.

15 years agoI had to change a bit of the stuff I added to get solaris openal working.
Kent Mein [Thu, 9 Dec 2004 13:13:24 +0000 (13:13 +0000)]
I had to change a bit of the stuff I added to get solaris openal working.

I also removed a redundant bit of config stuff for freebsd
that didn't do anything.

Kent

15 years agoThis fixes bug #1990
Kent Mein [Thu, 9 Dec 2004 13:09:11 +0000 (13:09 +0000)]
This fixes bug #1990

It moves targa, bmp, iris and png loading so that were not opening
2 file handles for each file, and made them like the jpeg stuff.

Also cleaned up some minor other stuff.

Kent

15 years agoBug fix #1988, ray-transparency render.
Ton Roosendaal [Thu, 9 Dec 2004 12:06:37 +0000 (12:06 +0000)]
Bug fix #1988, ray-transparency render.

Five fixes in this commit...

- the normals for nurbs surfaces still were calculated pointing wrong in some occasions
- recoded ray-transp rendering to accept normals pointing any direction; it just counts how many times it passes a "glass" layer, and flips normals appropriate then. This means rendering will go fine on models without manually setting the normals. You can also move a camera inside a 'glass' object.
- rendering of the inside part of glass now uses correct normal too... specularity happen on a solid glass inside now.
- And an inside reflected mirror ray will keep bouncing inside glass

Related to rendering localview: old convention to render localview, but with the lamps in the normal layers, has been restored.
Please note; render happens based on active window. You *only* get a localview or 'unlocked layer' render when that 3d window is active = mouse in window.

15 years agoBug fix based on bug report Chris Burt, IRC.
Ton Roosendaal [Wed, 8 Dec 2004 19:08:37 +0000 (19:08 +0000)]
Bug fix based on bug report Chris Burt, IRC.

Appending objects with constraints expands links to objects (according
code) but doesn't give such objects a link to Scene.

Apprently, somewhere in NaN days, someone commented a call, which
already invoked comments... here's the full code + comments now:

/* give a base to loose objects */
give_base_to_objects(G.scene, &(G.main->object));
/* has been removed... erm, why? (ton) */
/* 20040907: looks like they are give base already in append_named_part(); -Nathan L */
/* 20041208: put back. It only linked direct, not indirect objects (ton) */

:-)

15 years agoNarrowed code for restoring UI after undo. It seems still an error in
Ton Roosendaal [Wed, 8 Dec 2004 18:36:48 +0000 (18:36 +0000)]
Narrowed code for restoring UI after undo. It seems still an error in
oops code, having pointers to ID structs that are invalid.

This solves at least it crashing... oops needs to be refreshed once :)

(occurred on testing complex files, with conversion from nurbs=>mesh)

15 years agoBug fix #1987
Ton Roosendaal [Wed, 8 Dec 2004 15:29:47 +0000 (15:29 +0000)]
Bug fix #1987

Halos with texture, but only mapping to "Alpha" and not color, were
rendered black, instead of in material color.

15 years agoBug fix #1985
Ton Roosendaal [Wed, 8 Dec 2004 15:11:52 +0000 (15:11 +0000)]
Bug fix #1985

Using ctrl+up/down in buttons window, didn't use a proper rescale of view
as already works for dragging window edges. Now the 'Full window' action
keeps size nicely.

15 years agoremoved a debug printf. (excuse to check cvs permissions)
Rob Haarsma [Wed, 8 Dec 2004 15:11:38 +0000 (15:11 +0000)]
removed a debug printf. (excuse to check cvs permissions)

15 years agoThis commit makes it so openal finally works on solaris.
Kent Mein [Wed, 8 Dec 2004 14:58:40 +0000 (14:58 +0000)]
This commit makes it so openal finally works on solaris.

Kent

15 years agoEssential cleanup for mess involved with reading files, initializing UI and
Ton Roosendaal [Wed, 8 Dec 2004 14:12:47 +0000 (14:12 +0000)]
Essential cleanup for mess involved with reading files, initializing UI and
patching versions for UI settings.

Currently four different levels of routines for .blend file reading exist;

/* interface level */
1) BIF_init() -> calls 3
2) BIF_read_file() -> calls 11, optional 4
3) BIF_read_homefile() -> calls 11 or 12, and then 4
4) init_userdef_file()

/* kernel level */
11) BKE_read_file() -> calls 21, and then 14
12) BKE_read_file_from_memory() -> calls 22, and then 14
13) BKE_read_file_from_memfile() -> calls 23, and then 14
14) setup_app_data()

/* loader module level */
21) BLO_read_from_file() -> calls 24
22) BLO_read_from_memory() -> calls 24
23) BLO_read_from_memfile() -> calls 24

/* loader module, internal */
24) blo_read_file_internal()

Note:
- BIF_read_homefile() has additional UI initialize calls, like windows fullscreen and executing commandline options

- Reading from memory (12) only happens for the compiled-in .B.blend

- The "memfile" here is a name I gave to the undo "file" structure. Which is constructed out of memory chunks with basic compression features.

- the kernel function setup_app_data() sets globals like "current screen" and "current scene".

So far, so good. The levels as mentioned here clearly distinguish UI from kernel, and should enable for example game loading (runtime) or background (no UI) loading. In the past years however, 'bad level' dependencies were added, and especially the patches for 'file versions' were added in too many places. The latter is evidently a result of the problem that the "UserDef" struct cannot be initialized/patched if there's not a need for a UI.

Here's how the flow goes in four different cases:

----- Starting up Blender, in foreground with UI --------------------

- creator/creator.c, main() -> calls 1
- If the commandline contains a filename, it calls 11

----- Starting up Blender, in background without UI --------------------

- creator/creator.c, main() -> calls 11 if the commandline has a filename

Note: no Userdef is read, nor initialized. Please note that this was already an existing problem for using Yafray, not setting proper file paths in background mode. The Yafray paths don't belong in the User menu.

----- Starting up Blender as a runtime executable --------------------

This only has calls to 22

----- Loading a file from within the UI (with F1, CTRL+O, using pulldowns) -----

Only calls allowed to 2. It detects if a UserDef has been read too, and in that case the init_userdef_file() will be executed.

Hope this is understandable :)

-Ton-

15 years agoBug fix 1982
Ton Roosendaal [Tue, 7 Dec 2004 18:14:03 +0000 (18:14 +0000)]
Bug fix 1982

Three buttons, showing float values, had only precision of 2 digits.
Made it three.

15 years agoBugfix #1981
Ton Roosendaal [Tue, 7 Dec 2004 18:06:13 +0000 (18:06 +0000)]
Bugfix #1981

Pad-minus key didn't work in typemode transform().
Very easy, just flipping an && with || :)

15 years agoSneak in little feature for texture editing pleasure;
Ton Roosendaal [Tue, 7 Dec 2004 17:46:14 +0000 (17:46 +0000)]
Sneak in little feature for texture editing pleasure;

- New channel for "Map to" added, "Warp"
- Use the slider next to the option to set amount of influence the texture
  will have on the coordinates of the next texture.
- Warp uses for this the same values as for Normal or Displacement mapping
- Warp remains active for all channels, until replaced (or zeroed).

15 years agoMore tweaks related to bump mapping quality;
Ton Roosendaal [Tue, 7 Dec 2004 14:46:48 +0000 (14:46 +0000)]
More tweaks related to bump mapping quality;

While going over the code, I found out the "nabla", the size of offset
vectors for calculating derivatives of a texture, is a built in constant.
Even worse, the value was different for new noise types (musgrave etc).
So I've added a new slider for it in the procedural texture panels, which
by default is set to 0.025, the value of the old constant. Also made sure
it works with equal effect in all procedurals.

NOTE: a small Nabla will give sharper, detailed bump, but the effect also
becomes smaller, correct that in the Mapping Panel of materials.

For better & compliant control over the bumpmapping, I've also included
the Colorband output in derivatives calculus, so the bump output then
matches the color created. It's also a nice tool to finetune output of
textures for bumpmapping in general.

Bug fix; clicking on the rightmose 'item' in ColorBand didn't activate it.
Found out the ColorBand was slightly drawn off (2 pixels).

15 years agoAdded support for normalmaps.
Alfredo de Greef [Tue, 7 Dec 2004 05:31:17 +0000 (05:31 +0000)]
Added support for normalmaps.

15 years agoBug fix #1978
Ton Roosendaal [Mon, 6 Dec 2004 19:14:53 +0000 (19:14 +0000)]
Bug fix #1978

Stencil in World didn't work with RGB textures (like what returns from
colorbands).

15 years agoTweaked support for normalmaps to be OK.
Ton Roosendaal [Mon, 6 Dec 2004 18:05:42 +0000 (18:05 +0000)]
Tweaked support for normalmaps to be OK.

http://www.blender3d.org/cms/Normal_Mapping.491.0.html

main changes:
- The "Map Input" in Blender for normals was negated
- Range for Z in normal map is Z (0-1) to Blue (0-255)

15 years agoBug #1970
Ton Roosendaal [Mon, 6 Dec 2004 12:24:10 +0000 (12:24 +0000)]
Bug #1970

Objects being vertex-parented to a mesh, which in turn was being deformed
by a curve or lattice, were never update correctly.
Whilst this is a typical issue for our beloved new Dependency Graph, I
consider it worth at least solving for now. An issue since Blender 1.0
you know. :)

Solution is only working for this specific case; vertex-parent to deformed
object.

15 years agoFix the case when the physics system starves the logic & renderer of CPU time. If...
Kester Maddock [Mon, 6 Dec 2004 11:15:50 +0000 (11:15 +0000)]
Fix the case when the physics system starves the logic & renderer of CPU time.  If this happens, we reduce physics precision to maintain some framerate.

15 years agoFix numerical precision issue in physics. Dividing by a number too close to zero...
Kester Maddock [Mon, 6 Dec 2004 11:10:41 +0000 (11:10 +0000)]
Fix numerical precision issue in physics.  Dividing by a number too close to zero would make the impulse response normal large hence the jittering.

15 years agoSet the default physics tic rate to 90 Hz
Kester Maddock [Mon, 6 Dec 2004 11:01:42 +0000 (11:01 +0000)]
Set the default physics tic rate to 90 Hz

15 years agoDon't try to interpolate from prop ipo actuators
Kester Maddock [Mon, 6 Dec 2004 10:58:38 +0000 (10:58 +0000)]
Don't try to interpolate from prop ipo actuators

15 years agoBug fix #1972
Ton Roosendaal [Mon, 6 Dec 2004 09:57:01 +0000 (09:57 +0000)]
Bug fix #1972

AKEY didn't toggle open/close outliner. It'll be back temporal, until
definitely defined what to do with selections in it.

15 years agoOutliner crash reported bu K-rich;
Ton Roosendaal [Sun, 5 Dec 2004 23:24:43 +0000 (23:24 +0000)]
Outliner crash reported bu K-rich;

- with outliner visible
- alt+d (linked dupli) an armature

15 years agoBugfix: normal mapping for textures wasn't rotated back to view space,
Ton Roosendaal [Sun, 5 Dec 2004 21:49:13 +0000 (21:49 +0000)]
Bugfix: normal mapping for textures wasn't rotated back to view space,
causing weird results on camera moves or object rotations.

Added: support for "normal maps". See for example:
http://members.shaw.ca/jimht03/normal.html

The Image panel in Texture buttons has new option "Normal Map" for it.
When this is used, normals are read straight from RGB values, and blended
with the current normal.

15 years agoBugfix/feat request... in textured view mode the Build Effect didnt show.
Ton Roosendaal [Sun, 5 Dec 2004 21:46:30 +0000 (21:46 +0000)]
Bugfix/feat request... in textured view mode the Build Effect didnt show.

15 years agoReported on IRC;
Ton Roosendaal [Sun, 5 Dec 2004 12:05:28 +0000 (12:05 +0000)]
Reported on IRC;

Converting subsurf to mesh didn't display new Mesh object in correct wire,
when susurf was optimal.

15 years agoBPython, two bug fixes:
Willian Padovani Germano [Sun, 5 Dec 2004 04:01:57 +0000 (04:01 +0000)]
BPython, two bug fixes:
- #1911: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1911&group_id=9
    BOOL properties were returning True always, small mistake in logic.c's getData method.
- #1944: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1944&group_id=9
    G.vd was not being checked against NULL in Window.ViewLayer, causing a crash when this function was called from a command line script.  Now it returns an error in such cases.
- small doc updates, tiny minor change in Object.c.

15 years agoAdded support for the extra texture channels.
Alfredo de Greef [Sun, 5 Dec 2004 03:51:01 +0000 (03:51 +0000)]
Added support for the extra texture channels.

15 years agoFix Action & IPO actuators: (Bugs #1921 & #1920)
Kester Maddock [Sun, 5 Dec 2004 02:50:57 +0000 (02:50 +0000)]
Fix Action & IPO actuators: (Bugs #1921 & #1920)

15 years agoFix for bug #1875:
Kester Maddock [Sun, 5 Dec 2004 00:50:55 +0000 (00:50 +0000)]
Fix for bug #1875:

OpenAL (pthreads) was generating a SIGHUP at alcDestroyContext().

Fix by setting SIGHUP to ignore.

15 years agoSpecial bf-committers request; Lamp/World/Material now each have 10
Ton Roosendaal [Sat, 4 Dec 2004 21:49:02 +0000 (21:49 +0000)]
Special bf-committers request; Lamp/World/Material now each have 10
channels to link texture to.

The amount of code changes seems large, but is mostly getting rind of
hardcoded values (6 and 8) for channels, replacing it with MAX_MTEX.

Further did some fixes;
- Ipo for Lamp showed too many mapping channels
- Texture MapTo buttons for lamp missed the slider to blend texture color
- Lamp texture mapping "View" only worked for Spot, now it uses lamp-
  view vector for all types. (Nice for projections!)

15 years agoWas on my todo; with option "load No UI" the CTRL+X (start over) didnt
Ton Roosendaal [Sat, 4 Dec 2004 17:52:44 +0000 (17:52 +0000)]
Was on my todo; with option "load No UI" the CTRL+X (start over) didnt
load UI either.

(editmesh commit is error in previous commit, but caused no harm)

15 years agoBug fix #1955
Ton Roosendaal [Sat, 4 Dec 2004 14:29:57 +0000 (14:29 +0000)]
Bug fix #1955

Another tweak in the convex formula, replaced a ">" with ">=" for detecting
optimal projection of face in 2d. Solves issue reveiled in Bevel tool,
where it could happen that a face wasn't created.

15 years agoBug fix #1954
Ton Roosendaal [Sat, 4 Dec 2004 12:02:19 +0000 (12:02 +0000)]
Bug fix #1954

Edge render for wire in unified was total mess! Code there apparently never
even tested. Gave wrong rendering and potential crashes.

15 years agoBug #1957
Ton Roosendaal [Sat, 4 Dec 2004 10:51:04 +0000 (10:51 +0000)]
Bug #1957

Blender ALT+Z drawmode didnt support quad lights.

15 years agoUpdate the physics engine: interpolate between frames so track to/camera actuators...
Kester Maddock [Sat, 4 Dec 2004 09:51:04 +0000 (09:51 +0000)]
Update the physics engine: interpolate between frames so track to/camera actuators work properly. (bug #1816)

15 years agoBugfix for #1949:
Brecht Van Lommel [Sat, 4 Dec 2004 00:12:53 +0000 (00:12 +0000)]
Bugfix for #1949:

F11 to switch between render window / main window didn't work anymore in some
window managers (e.g. fluxbox), after fixing it to work in kde.

15 years agoTwo small fixes;
Ton Roosendaal [Fri, 3 Dec 2004 23:22:21 +0000 (23:22 +0000)]
Two small fixes;

- on exit editmode, displist for subsurf was not made, causing static
  particles to calculate wrong
- static particles were not selectable

15 years ago- added undo pushes for buttons invoking file window in scene buttons
Ton Roosendaal [Fri, 3 Dec 2004 22:04:28 +0000 (22:04 +0000)]
- added undo pushes for buttons invoking file window in scene buttons
  (set directory, backbuf, scene)
- small annoyance; after extrude the transform() didn't react to the
  "midtog" feature (middlemouse constraint)

15 years agoBug fix #1952
Ton Roosendaal [Fri, 3 Dec 2004 21:25:56 +0000 (21:25 +0000)]
Bug fix #1952

When rotating camera itself in camera view, and choose local axis rotate,
the camera flipped around. Was due to using viewmat[][] while it changes...

Solved in the simplest elegant way; hope Martin will cope with this in new
transform!

15 years agoBug fix #1945
Ton Roosendaal [Fri, 3 Dec 2004 20:41:53 +0000 (20:41 +0000)]
Bug fix #1945

Undo push missing after "ALT/SHIFT+D and ESC".

15 years agoFixes in static particles. Result of going over details with Chris Burt,
Ton Roosendaal [Fri, 3 Dec 2004 20:22:37 +0000 (20:22 +0000)]
Fixes in static particles. Result of going over details with Chris Burt,
thanks for that!

- static particles that are being deformed (curve/lattice/armature) now
  display correct in 3d window. Only updates when particle system updates
  normally though
- static particles without "animate" set didn't deform even
- static particles used as duplicators had errors with extreme low "life"
  value for particles. Also, still cases could happen with unrotated duplis
  at the end of a static particle line (with Vect option)
- Added tooltip for "Step" option in particles

15 years agoBug fix #1946
Ton Roosendaal [Fri, 3 Dec 2004 18:04:33 +0000 (18:04 +0000)]
Bug fix #1946

Editmode Mesh, edge selectmode, not zbuffer on. Selecting edges didnt give
a small disadvantage to the already selected one, making it hard to select
edges that are extreme close or on top of each other.

15 years agoBug fix #1947
Ton Roosendaal [Fri, 3 Dec 2004 17:03:35 +0000 (17:03 +0000)]
Bug fix #1947

Unified render added sky with alpha=1. Found the way how to fix it, didnt
dare that yesterday. :)
Now sky is rendered with alpha=0, like normal render.

Thanks to the recent reports, a lot of old issues with unified render have
been solved. This is going to be pretty OK!

15 years agoBug fix #1948
Ton Roosendaal [Fri, 3 Dec 2004 16:44:48 +0000 (16:44 +0000)]
Bug fix #1948

When using a backbuffer with alpha, but alpha is not premulled, you can
get weird rendering results with halos or lens flare. This was caused by
optimize rule in alpha routine that assumed alpha==0 means color is zero.
Removed for the the halo case.

15 years agoFixed the very annoying display of User Settings Menu when Blender window
Ton Roosendaal [Fri, 3 Dec 2004 16:32:24 +0000 (16:32 +0000)]
Fixed the very annoying display of User Settings Menu when Blender window
is wider than 1280 pixels. It now keeps scale at 100% then, without zoom.

15 years agoFix for #1951
Ton Roosendaal [Fri, 3 Dec 2004 15:28:48 +0000 (15:28 +0000)]
Fix for #1951

Textbuttons and buttons showing ID names (Objects, etc) were accidentally
also translated. Error since 2.3 recode. :)

15 years agoFix for #1700 and #1941
Ton Roosendaal [Fri, 3 Dec 2004 14:30:32 +0000 (14:30 +0000)]
Fix for #1700 and #1941

When a font for 3d Text Object doesnt exist anymore, Blender could crash.
Thanks Rob Haarsma for fixing it.

15 years agoBufix for #1940
Ton Roosendaal [Fri, 3 Dec 2004 10:16:29 +0000 (10:16 +0000)]
Bufix for #1940

With material slider "Ray Mir" set non zero, but with toggle "Ray Mirror"
off, Blender accidentally entered a part of raytracing code, screwing up
the alpha value of the result.

15 years agoAdded
Kent Mein [Fri, 3 Dec 2004 02:42:21 +0000 (02:42 +0000)]
Added
#define B_UNLINKIMA            1358

Since it was undefined and causing things not to compile.  Whoever added it
might want to move it but hey its working again for now. ;)

Kent

15 years agoFix, reported on irc by K-rich.
Ton Roosendaal [Thu, 2 Dec 2004 22:39:16 +0000 (22:39 +0000)]
Fix, reported on irc by K-rich.

Texture buttons didn't allow to unlink the image. Nowhere in Blender this
even is possible or happens... reason for blocks to get "stuck" in file. :)

15 years agoAdded new option:
Ton Roosendaal [Thu, 2 Dec 2004 21:22:17 +0000 (21:22 +0000)]
Added new option:

In renderwindow, press AKEY to see the alpha in B&W. Another AKEY shows
normal RGB again. This uses glColorMask, an opengl 1.0 function.
Really needed it for debugging alpha in rendering. :)

15 years agoBufix #1942
Ton Roosendaal [Thu, 2 Dec 2004 21:18:58 +0000 (21:18 +0000)]
Bufix #1942

Halos with Flare option didn't render correct in Unified render, they were
added twice!
Also noticed errors in applying alpha for 'Premul' alpha in Unified. Fixed.

15 years agoBug fix #1939
Ton Roosendaal [Thu, 2 Dec 2004 18:12:18 +0000 (18:12 +0000)]
Bug fix #1939

Combining panorama scene and Sequencer effect on scene (like glow) crashed.

Found two other issues;

- on click in sequencer, the image output window didn't redraw correct, but
  only when a render window was opened. Caused by missing 'activate' call
- added a pause in dragging-frame loop to make it idle friendly

15 years agoReported on IRC, Wavez:
Ton Roosendaal [Thu, 2 Dec 2004 16:08:49 +0000 (16:08 +0000)]
Reported on IRC, Wavez:

Objects with negative scale draw TFaces front/back inverted in FaceSelect
mode. Added same solution as 2 releases before for Solid draw mode.

15 years agoSelection on faces now includes the facedots in solid/visible-only mode.
Ton Roosendaal [Thu, 2 Dec 2004 16:01:15 +0000 (16:01 +0000)]
Selection on faces now includes the facedots in solid/visible-only mode.

15 years agoBug fix #1937
Ton Roosendaal [Thu, 2 Dec 2004 14:52:40 +0000 (14:52 +0000)]
Bug fix #1937

In unified render, halos can give black/colored overflows. Found it this
happens with halos that are behind the camera clipping range. Halo clip
just had some weird code for panorama corrections...

In the provided .blend of report found 3 more glitches;

- after render particle system with Material Ipo, values for material were
  not restored correctly
- Meshes with particles didn't draw axis (draw extra) on correct location
- Same as above, axis didn't draw in selected color.

15 years agoBug fix #1935
Ton Roosendaal [Thu, 2 Dec 2004 12:37:08 +0000 (12:37 +0000)]
Bug fix #1935

Using header view3d pulldown for "align active camera to view" didn't clear
the abused modifier value correctly. Learn from this:

incorrect: G.qual &= ~LR_CTRLKEY|LR_ALTKEY;
correct:   G.qual &= ~(LR_CTRLKEY|LR_ALTKEY);

15 years agobugfix: #1930 Mathutils.Euler constructor fails to initialize class variables
Stephen Swaney [Wed, 1 Dec 2004 23:09:59 +0000 (23:09 +0000)]
bugfix: #1930 Mathutils.Euler constructor fails to initialize class variables

Euler object was holding pointer to bad memory.
Euler now owns internal array memory and frees it in destructor.

15 years agoThree little fixes as reported by Campbell;
Ton Roosendaal [Wed, 1 Dec 2004 22:35:42 +0000 (22:35 +0000)]
Three little fixes as reported by Campbell;

- Mesh editmode; SHIFT+F fill didnt set default vertex color
- Parented spotlight had wrong (black) dashed line to parent when selected
- Constraint line draw while transform wasn't reset, causing sometimes to
  draw when using the (ugly) G.moving flag...

15 years agoFixed old annoyance in Blender;
Ton Roosendaal [Wed, 1 Dec 2004 20:10:08 +0000 (20:10 +0000)]
Fixed old annoyance in Blender;

With mouse cursor over a screen-edge (between windows) none of the hotkeys
worked. Now it checks for the global list of keys, including screen-switch,
quit, frame change, Fkeys, load/save, undo/redo, etc.

15 years agoBug fix #1922
Ton Roosendaal [Wed, 1 Dec 2004 19:46:58 +0000 (19:46 +0000)]
Bug fix #1922

Gauss filtered render now supports using Part render too.
Solved by increasing part sizes with 1 pixel around, but only with gauss
set.

15 years agoBuf fix #1928
Ton Roosendaal [Wed, 1 Dec 2004 16:47:26 +0000 (16:47 +0000)]
Buf fix #1928

Bug in Unified render with Edge outline option. Appeared to be lack of
setting buffer pointers at NULL after a render. Bad one, oldie. :)

15 years agoBug #1924
Ton Roosendaal [Wed, 1 Dec 2004 15:57:33 +0000 (15:57 +0000)]
Bug #1924

In PoseMode, selecting multiple bones and transform() it crashes.
Found out the bones were not even counted at all! Bug since 2.25...

15 years agoBug #1909
Ton Roosendaal [Wed, 1 Dec 2004 12:39:14 +0000 (12:39 +0000)]
Bug #1909

When choosing "render engine" in Scene Buttons, the newly added or removed
Panels didn't invoke a re-alignment event yet.
Also added code that inserts new panels as good as possible on their
previous locations. This works reliable for 1 new panel, not for more, this
because a Panel only stores its old location, not the locations of all
Panels in a given configuration. Consider that minor issue...

15 years agoOnly do event processing for ipo actuators on frames.
Kester Maddock [Wed, 1 Dec 2004 08:43:58 +0000 (08:43 +0000)]
Only do event processing for ipo actuators on frames.

15 years agoMake objects lit by default if there is a light in the scene, and no other face infor...
Kester Maddock [Wed, 1 Dec 2004 08:43:02 +0000 (08:43 +0000)]
Make objects lit by default if there is a light in the scene, and no other face information exists for that object.

15 years ago.scr patch (from Raymond Penners)
Kester Maddock [Wed, 1 Dec 2004 08:35:38 +0000 (08:35 +0000)]
.scr patch (from Raymond Penners)

- The patch only alters files in: blender/source/gameengine/GamePlayer/ghost

- Any blenderplayer.exe (with the patch applied) can be renamed into
something.scr, and it will behave as a Windows screen saver.
(Right-click the .scr file, and select "Install". Then, it will appear
in the screen saver properties dialog part of the display settings,
including small preview et al).

- The screen saving functionality does not affect the executable when
it is NOT named .scr

- The screen saver automatically exits when the mouse/keyboard is
moved/pressed. There is no more need to wrap blenderplayer.exe into a
bat file and use python quit controllers, or whatever else is
suggested at http://download.blender.org/documentation/oldsite/oldsite.blender3d.org/181_Blender%20news%20haloParty.html

- It has been currently been tested to work Windows XP

15 years agoScripts:
Willian Padovani Germano [Wed, 1 Dec 2004 04:49:04 +0000 (04:49 +0000)]
Scripts:
-- Campbell Barton updated some of his contributions, thanks!

15 years agoBugfix #1915
Ton Roosendaal [Tue, 30 Nov 2004 22:46:13 +0000 (22:46 +0000)]
Bugfix #1915

In unified render, AO with option "Sky" could give black dots, caused by
an overflow due to division by zero (was clipped away in normal render).

15 years ago- Bug fix #1913
Ton Roosendaal [Tue, 30 Nov 2004 22:32:52 +0000 (22:32 +0000)]
- Bug fix #1913
Lasso select on objects didnt work with multiple views, due to lack of
calculation of screencoords.

- Bug fix #1914
Hooks didn't update 'parent' when snapping to grid a Hook. Solved it for
snap to cursor too.

15 years agoRemoved an unused variable and the autoconf config.h stuff.
Kent Mein [Tue, 30 Nov 2004 19:10:43 +0000 (19:10 +0000)]
Removed an unused variable and the autoconf config.h stuff.
(was hunting down why audio isn't working on solaris and figured
I'd clean up the warning)

Kent

15 years agoOn report from IRC: expand/shrink selection (CTRL + numpad-plus/minus) did
Ton Roosendaal [Tue, 30 Nov 2004 13:06:00 +0000 (13:06 +0000)]
On report from IRC: expand/shrink selection (CTRL + numpad-plus/minus) did
not work with edge/face selection modes correctly yet.

15 years agoScripts:
Willian Padovani Germano [Tue, 30 Nov 2004 02:27:46 +0000 (02:27 +0000)]
Scripts:
- Fixes by Jean-Michel Soler: mod_ai2obj.py, mod_svg2obj.py;
- Fixes by Campbell Barton: obj_import.py;
- Small fix to mod_meshtools.py (fixes bug #1605: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1605&group_id=9);
- Updates by Jean-Baptiste (Jiba) to his blender2cal3d.py;
- Updates to all his import / export scripts (added doc data) by Anthony D'Agostino;
- Update to off_import: support for uv data, by Arne Schmitz.

BPython:
- Removed Object.get and .getSelected (deprecated long ago, we use .Get and .GetSelected) -- fixes #1861: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1861&group_id=9
- Applied patch by Michael Reimpell: quat.c - fix for wrong initialization with newQuaternionObject; Mathutils documentation improvements.
- Stani reported a wrong return msg in IpoCurve.Get (that is unimplemented).

Thanks to all coders mentioned above!

15 years agofix for #1590, possible fix for #1849 (to be confirmed)
Jean-Luc Peurière [Mon, 29 Nov 2004 20:36:03 +0000 (20:36 +0000)]
fix for #1590, possible fix for #1849 (to be confirmed)
OpenAl is subtly different on each platform. Os X need the alutinit/exit stuff

15 years agoFixed fgon issues;
Ton Roosendaal [Mon, 29 Nov 2004 12:57:35 +0000 (12:57 +0000)]
Fixed fgon issues;

- removed rule restricting to co-planar fgons; isn't useful anyway. Now
  allows to fgonize the entire surface of a tube :)
- Hide/Reveil fgons cleared fgon flags
- Reveil ended with wrong selection status for verts/edges... solved with
  correctly using EM_select_edge and EM_select_face

15 years agoBug reported by Wavez;
Ton Roosendaal [Mon, 29 Nov 2004 12:15:25 +0000 (12:15 +0000)]
Bug reported by Wavez;

Leftmouse select option doesn't work with "Emulate 3 button mouse" option.
The latter maps middle mouse to ALT+leftmouse, frustrating loop select for
example.

Add tooltip to say this, made option to disable automatic on load (version
check) and made buttons redraw to show option being disabled.

Note; wrapping middle mouse to ALT+RMB will frustrate 1 button mices... the
current code for leftmouse-select is a hack at best, better do this good
when we have proper event handlers system.

15 years agobug #1897: Added check to make sure plugin actually loaded correctly.
Alfredo de Greef [Mon, 29 Nov 2004 05:33:32 +0000 (05:33 +0000)]
bug #1897: Added check to make  sure plugin actually loaded correctly.

15 years agoAck, previous commit (4 hr ago) cancelled out recalculating lookop tables
Ton Roosendaal [Sun, 28 Nov 2004 23:11:41 +0000 (23:11 +0000)]
Ack, previous commit (4 hr ago) cancelled out recalculating lookop tables
for Gaussian filter.

15 years agoImproved rule for selecting objects in solid view, the old method skipped
Ton Roosendaal [Sun, 28 Nov 2004 22:29:28 +0000 (22:29 +0000)]
Improved rule for selecting objects in solid view, the old method skipped
selection when clicked object was already active (didnt deselect others,
nor select active when it was not selected).

15 years agoFixed something that annoyed me for ages;
Ton Roosendaal [Sun, 28 Nov 2004 19:48:53 +0000 (19:48 +0000)]
Fixed something that annoyed me for ages;

In Object mode, Solid drawing, selection was just always not what you
wanted, the rules for wireframe (cycling) can't be used then.

New rule is;
- it always selects the frontmost visible item (wires in solid too), unless
  - frontmost is active already, then it picks the 2nd
  - mouse didnt move 2 pixels while selecting, then it starts cycling

Works nice :)

15 years agoBug fix #1903
Ton Roosendaal [Sun, 28 Nov 2004 18:35:40 +0000 (18:35 +0000)]
Bug fix #1903

Bug in Nurb Surface orco, causing illegal pointer to be set, and crash.
Another oldie, pre-2.25!

15 years agoFix for #1902
Ton Roosendaal [Sun, 28 Nov 2004 18:14:57 +0000 (18:14 +0000)]
Fix for #1902

For composting sky behind alpha, a gamma corrected alpha_under was used,
but Blender didnt make the gamma tables unless OSA was set.
Old bug!

Changed; while rendering with "Backbuf" that doesn't exist, blender still
renders, but without backfbuf now. It used to stop render and return, with
only a print in console... confusing.

15 years agoFix for unified rendering;
Ton Roosendaal [Sun, 28 Nov 2004 14:28:55 +0000 (14:28 +0000)]
Fix for unified rendering;

Gaussian sampling/rendering now supported too!
Also corrected gamma corrected adding of colors, which gives better alpha
and blending with sky than normal render does. The latter I could check
once too...

15 years agocleaning commit
Jean-Luc Peurière [Sun, 28 Nov 2004 12:14:27 +0000 (12:14 +0000)]
cleaning commit
shut the warnings GCC was producing for Os X

15 years agoNot really bug, but fix for report in tracker;
Ton Roosendaal [Sun, 28 Nov 2004 11:32:55 +0000 (11:32 +0000)]
Not really bug, but fix for report in tracker;

Added more support for lasso select; it now does:
- UV FaceSelect
- Editmode curve, surface, lattice

Missing: MBall and Armature; these make use of opengl selection still.

15 years agoBug fix #1842, "black scanlines appear in render on windows".
Ton Roosendaal [Sun, 28 Nov 2004 10:31:18 +0000 (10:31 +0000)]
Bug fix #1842, "black scanlines appear in render on windows".

Thanks to Brecht & Valgrind, found 2 cases for unitialized variables in
the render code. Both were for 2D texture input (Window and Sticky) which
didn't initalize a the third coordinate. Goes fine for 2D textures, but not
for 3d ones :)

15 years agoAdded nearly full support for Blender's procedural textures, with the exception
Alfredo de Greef [Sun, 28 Nov 2004 02:13:57 +0000 (02:13 +0000)]
Added nearly full support for Blender's procedural textures, with the exception
of 'envmap', 'magic', and 'plugin' modes.
The stucci texture also is not exact match, since it cannot be fully
emulated in yafray because of implementation issues. It will work best
for low turbulence values (which is actually not taken into account
in the export code).
Also, since Blender's static noise is basically just direct random number
output, don't expect the exact same result when rendered in yafray, but in this
case that probably shouldn't be that much of a problem...
(needs yafray from cvs)

(btw, on a side note, I put this in the comments once when working on the noise
stuff for Blender, but noise is affected by the 'depth' parameter, and there
is no way to control this directly from the GUI, can only be done by temporarily
switching to 'clouds' for instance.)

15 years agoReport #1841
Ton Roosendaal [Sat, 27 Nov 2004 18:47:51 +0000 (18:47 +0000)]
Report #1841

Crash in this situation;
- one blender file with more scenes
- render image
- goto another Scene with no camera and larger output size for image
- render

Render buffer has to be freed then :)

15 years agoBPython:
Willian Padovani Germano [Sat, 27 Nov 2004 18:32:26 +0000 (18:32 +0000)]
BPython:
- fixed bug #1882: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1882&group_id=9
    Crash / hang when changing meshes that had edge data.  The mesh->totedge value was not being set to 0.  Reported by jms, thanks.
- fixed bug #1780: https://projects.blender.org/tracker/index.php?func=detail&aid=1780&group_id=9&atid=125.
    Deleting a Text that was being used as script link crashed Blender.  Added a check to unlink the Text from eventual script links when it gets removed.  Reported by kaito, thanks.
- doc updates (one related to bug #1807: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1807&group_id=9 , actually a little misleading word in the NMesh doc: you can get the subsurfed mesh with NMesh.GetRawFromObject, but it's the display subdivision level that counts).

15 years ago- draw compatibility with engine; without lights texture-less objects
Ton Roosendaal [Sat, 27 Nov 2004 17:59:16 +0000 (17:59 +0000)]
- draw compatibility with engine; without lights texture-less objects
  draw shadeless
- buttons for physics in Material menu lined up

15 years ago- Bug fix, reported by Stefano;
Ton Roosendaal [Sat, 27 Nov 2004 17:33:40 +0000 (17:33 +0000)]
- Bug fix, reported by Stefano;
  - Ztransp material didn't raytrace at all (now just traces it entirely,
    remember too set the transp depth for it)
  - tramsparent material reflected wrong in mirror material, due to
    specular being added without alpha.
- Cleaned up some code to improve raytrace speed some. The old conventions
  from before the AA recode were still there, this allowed coherence for
  octree traversal. Current AA doesn't allow this anymore.
  Added is improved check for 'first hit' on shadow render, per lamp this
  now is stored
  All in all, render with ray trace improved about 10-15%.

15 years agoBug fix #1893
Ton Roosendaal [Fri, 26 Nov 2004 20:20:42 +0000 (20:20 +0000)]
Bug fix #1893

Option to switch left/right mouse didn't work for floating panels. It then
still selected stuff behind the button.
Was due to using wrong variable for events.

15 years agoFixes in reading .dxf (bug #1883)
Ton Roosendaal [Fri, 26 Nov 2004 19:59:11 +0000 (19:59 +0000)]
Fixes in reading .dxf (bug #1883)

- fgets() doesn't recognize DOS strings in unices, made my own fgets
- reading polyline didnt support 3d lines
- reading polyline didn't create edges

All in all, this code isn't very nice and badly structured... a code
review or test (yes sirdude!) could have been useful. :)

15 years agoTwo fixes;
Ton Roosendaal [Fri, 26 Nov 2004 12:20:35 +0000 (12:20 +0000)]
Two fixes;

- Bug #1890. While render subsurf in editmode, orco coordinates were
  incorrect (subsurf vertices in editmode have different ordering)
  Bug was oldie.
- IRC reported by Stefano; oops (not outliner) didnt show lamp textures
  nor material ipos correctly.
  Found error in oops curved lines too (the ones starting at right side)

15 years agoSmall tweaks to make 3d drawing a tad more interactive, and; something
Ton Roosendaal [Thu, 25 Nov 2004 21:52:07 +0000 (21:52 +0000)]
Small tweaks to make 3d drawing a tad more interactive, and; something
for our interactive 3d artists!

- AL+Z (potato) texture view now draws objects without Texture Faces
  compliant with (new) default in engine. Meaning lit faces, using
  Material RGB for diffuse and specular. It used to draw these as 'shaded'
  which is quite useless.
  Per definition, Potato mode is supposed to show what engine draws.
  (Note; this only for Mesh objects)

- Added a couple of more calls to ensure Shaded drawmode updates on
  changing RGB sliders, moving lamps to layers, or switch layers

This based on feedback from Mal, who'll also give it all good tests.

15 years agoFix for #1806
Ton Roosendaal [Thu, 25 Nov 2004 18:16:50 +0000 (18:16 +0000)]
Fix for #1806

View3d windows have 'unlock' option and 'localview', which was also
supported on render (F12 with mouse in window) to render only what is
visible there.
This didn't work very nice, with even code in render module to read from
interface variable. Removed that from render, and coded the exception
where it belongs, in renderwin.c