blender.git
14 years agoEeek! last minute error.
Ton Roosendaal [Tue, 21 Dec 2004 18:49:31 +0000 (18:49 +0000)]
Eeek! last minute error.
Commit of dec 9... still uses fopen(name, "ab") instead of "wb"
Caused targa and bmp files to write wrong on save-over, appended instead.

14 years agoAccidentally committed corrupt SConstruct.... here's the one fixed
Ton Roosendaal [Tue, 21 Dec 2004 17:00:25 +0000 (17:00 +0000)]
Accidentally committed corrupt SConstruct.... here's the one fixed

14 years agoUpped sconstruct for 2.36 release
Ton Roosendaal [Tue, 21 Dec 2004 16:25:37 +0000 (16:25 +0000)]
Upped sconstruct for 2.36 release

14 years agoUpped version for makefiles, and new splash (original image)
Ton Roosendaal [Tue, 21 Dec 2004 16:24:29 +0000 (16:24 +0000)]
Upped version for makefiles, and new splash (original image)

14 years agoUpped release code to 2.36
Ton Roosendaal [Tue, 21 Dec 2004 16:23:24 +0000 (16:23 +0000)]
Upped release code to 2.36

14 years ago- release log 2.36
Ton Roosendaal [Tue, 21 Dec 2004 16:19:36 +0000 (16:19 +0000)]
- release log 2.36
- added note in copyright.txt to emphasis you can use blender artwork
  freely
- removed old logs, current log contains link to the old ones on the web

14 years agoFix for 2042
Ton Roosendaal [Tue, 21 Dec 2004 12:10:35 +0000 (12:10 +0000)]
Fix for 2042

With the new rule that allows correct calculation of vertex normals on a
mixed solid/smooth mesh, it is essential that vertex normals get
recalculated when changing smooth settings. Such a facility doesnt exist
in Blender yet, only after leaving editmode.
Hacking in a "enter editmode, leave editmode" event on the "Set Smooth"
button isn't nice... instead I've tweaked the calculus of vertexnormals
that it always sets them OK, apart from where they get mixed with solid
faces. Only in rare occasions this can still go "wrong" and needs a
TAB-TAB to fix. Will add that comment in release notes. For next release
we should definitely solve this smoothing bizz!

14 years agobugfix: #2031 World setIpo() method checks for wrong IPO type
Stephen Swaney [Tue, 21 Dec 2004 01:34:23 +0000 (01:34 +0000)]
bugfix: #2031 World setIpo() method checks for wrong IPO type

wrong constant name.

14 years agobugfix: #2032 Ipo_woIcuName() uses CAM instead of WO constants
Stephen Swaney [Tue, 21 Dec 2004 01:15:42 +0000 (01:15 +0000)]
bugfix: #2032  Ipo_woIcuName() uses CAM instead of WO constants

Wrong constant names.  Fix contributed by Joilnen B. Leite <pidhash>

14 years agoBugfix for #2036
Ton Roosendaal [Mon, 20 Dec 2004 18:11:20 +0000 (18:11 +0000)]
Bugfix for #2036

Backbuffer selection codes issue on OSX.
On some h/w configs, with "1000s of colors set", the drivers seem to round
colors up or down... whilst until now rounding always was just truncating
bits. This gives errors in writing color codes and reading it back.
The c code only changed for OSX. For other OS's and HW this test could be
done as well.

14 years agoFix in hook menu; "select" option only worked in vertex selectmode.
Ton Roosendaal [Sun, 19 Dec 2004 18:38:17 +0000 (18:38 +0000)]
Fix in hook menu; "select" option only worked in vertex selectmode.

14 years agoFix for #2034
Ton Roosendaal [Sun, 19 Dec 2004 18:18:54 +0000 (18:18 +0000)]
Fix for #2034

It appeared that the method as used in unified render for "render all sub-
pixels" isn't very well resistant to having large amounts of faces in a
single pixel. The bug file had about 16x70x2 faces per pixel... causing
tremendous slowdown and even wrong render.

I've disabled the option (was coded by Nzc in NaN days) and made it
sampling in the main render loop. Goes much faster, error free. Only loss
is in that it doesnt use superiour subsamples for gauss anymore. Here the
normal render performs slightly better. Not a real issue though. Hard to
notice.

14 years agoFixed adding a filename extension for bmp images.
Rob Haarsma [Sun, 19 Dec 2004 18:06:28 +0000 (18:06 +0000)]
Fixed adding a filename extension for bmp images.

14 years agoBugfix, reported by Basse: static particles didnt render correct with
Ton Roosendaal [Sun, 19 Dec 2004 18:04:48 +0000 (18:04 +0000)]
Bugfix, reported by Basse: static particles didnt render correct with
"Layer" Lamp. Was just missing a value being written in halo struct.

14 years agoBug fix #2026
Ton Roosendaal [Sun, 19 Dec 2004 14:19:20 +0000 (14:19 +0000)]
Bug fix #2026

Slightly altered rules for calculating vertexnormals. By only averaging
face normals from faces actually set 'smooth', the result looks much more
nice (for example on a cylinder with caps solid). Vertex normals not being
used by smooth faces are set to the face normal direction.

Shows both in editor as rendering.

14 years agoA one-line commit; Quicktime movies used as texture are now loaded at the highest...
Rob Haarsma [Sun, 19 Dec 2004 13:45:03 +0000 (13:45 +0000)]
A one-line commit; Quicktime movies used as texture are now loaded at the highest quality.
I noticed Quicktime did not display interlaced fields for DV movies, it works OK now !

14 years agobugfix: #2025 getCurveBP (and others) segfault
Stephen Swaney [Fri, 17 Dec 2004 17:34:51 +0000 (17:34 +0000)]
bugfix: #2025  getCurveBP (and others) segfault

This method is now unsupported.  The original intent appears to
return the first BPoint of an Ipo curve.  However, BPoint Ipo curves
are not implemented and the first point therefore never existed.

The segfault was from an unchecked input parameter.

Calling this method now always throws a NotImplemented exception.

14 years agoIncreased builtin limit for selection buffer (border select in Object mode)
Ton Roosendaal [Thu, 16 Dec 2004 14:42:10 +0000 (14:42 +0000)]
Increased builtin limit for selection buffer (border select in Object mode)
to allow up to 2500 objects (was 500).
Still an arbitrary limit, could use better code. For now its less
frustrating :)

14 years agoErrors in saving runtime, and fileops in file window; files were copied
Ton Roosendaal [Thu, 16 Dec 2004 14:40:25 +0000 (14:40 +0000)]
Errors in saving runtime, and fileops in file window; files were copied
or deleted without keeping track of spaces in names, causing in potential
loss of data.

Needs review!

14 years agoBug #2019
Ton Roosendaal [Wed, 15 Dec 2004 11:36:46 +0000 (11:36 +0000)]
Bug #2019

Separate in Mesh editmode, selectmode 'face', and with a selection that
used to be in vertex mode a full select (like selecting the 2 opposing
faces in a cube) caused crash. There was still no good face-select
awareness there... tsk! :)

14 years agoFix for #2017
Ton Roosendaal [Tue, 14 Dec 2004 22:01:52 +0000 (22:01 +0000)]
Fix for #2017

Actually a 1 liner fix, added displist re-make event for wave objects
being used to vertexparent objects to. Will of course be much better
solved with the dep graph!

14 years agoSmall fixes for UI;
Ton Roosendaal [Tue, 14 Dec 2004 18:18:31 +0000 (18:18 +0000)]
Small fixes for UI;

- Add UV Sphere now aligns with view, as do all primitives
- Small drawing error in edges between blender areas (black lines were 2
  pixels too short)
- Replaced the heuristics in opening sublevel menus, to be less frustrating.
  It now keeps sublevel open while mouse moves within the triangle defined
  by original mouse location (before moving) and the closest vertical edge
  of the new sub menu. Works nice for toolbox and pulldowns.

14 years agoBug fix #2016
Ton Roosendaal [Tue, 14 Dec 2004 18:12:30 +0000 (18:12 +0000)]
Bug fix #2016

Particles added to mesh being deformed with Armature crashes.
Bug introduced with 2.33, particle collisions... leon added some fancy
updates for actions and armature displists there, which are highly
disputable. I left it in, because I didn't see it was actually new.

Note: particles added while updating mesh with armatures is not supported,
it will shoot particles from original location.
What does work, is static particles.

14 years agoMakefile didnt copy files correctly, obviously because the nan_definitions
Ton Roosendaal [Tue, 14 Dec 2004 13:08:17 +0000 (13:08 +0000)]
Makefile didnt copy files correctly, obviously because the nan_definitions
were not there...

14 years agoWhile giving snapto a good test (thanks all_select.blend!) I found it was
Ton Roosendaal [Mon, 13 Dec 2004 17:11:33 +0000 (17:11 +0000)]
While giving snapto a good test (thanks all_select.blend!) I found it was
not implemented on MetaBall editmode, causing an old global var to wreak
havoc.

14 years agoBug fix #2013
Ton Roosendaal [Mon, 13 Dec 2004 16:46:40 +0000 (16:46 +0000)]
Bug fix #2013

Face dots didn't recalculate after a 'snap to grid' or 'snap to cursor'.

14 years agoSTEP macro was a typo waiting to happen.
Kent Mein [Mon, 13 Dec 2004 13:51:35 +0000 (13:51 +0000)]
STEP macro was a typo waiting to happen.

Fix done by LetterRip.

Kent

14 years agoSet the physics scale on added objects. (Fix bug #1837)
Kester Maddock [Mon, 13 Dec 2004 09:53:30 +0000 (09:53 +0000)]
Set the physics scale on added objects. (Fix bug #1837)

14 years agoReset backface culling. (Fix bug #1960)
Kester Maddock [Mon, 13 Dec 2004 09:10:58 +0000 (09:10 +0000)]
Reset backface culling. (Fix bug #1960)

14 years agoBug fix, after irc report sk1p:
Ton Roosendaal [Sun, 12 Dec 2004 21:13:07 +0000 (21:13 +0000)]
Bug fix, after irc report sk1p:

frame-sliding (LMB) in action, nla, sound and ipo window went into very
tight while loop, causing cpu to choke. Added nice idle.

Bug fix, found self while testing:
- relative.blend, editmode
- delete part, exit editmode
- enter editmode, undo twice, exit editmode -> crash

The trick to copy 'old' locations of vertices to keys isnt undo-resistant
yet. This fix at least doesnt crash, but copying doesnt work when undo-ing
back to previous editmode session (indices just differ from current mesh...)

14 years agoBug, reported by Bassam;
Ton Roosendaal [Sun, 12 Dec 2004 19:06:04 +0000 (19:06 +0000)]
Bug, reported by Bassam;

When editing Meshes with vertex keys (RVKs), the undo stack isn't
updated correctly, causing a loss of the situation when entering
editmode after changing active key, and doing undo immediate after.

This due to an 'optimizer' in the undo code that tried to prevent undos
pushed on identical situations (e.g. pressing TAB multiple times).
Decided to remove that convention, the annoyance of having possible
multiple undos in a row isn't worth solving it by potential losses.

14 years agoBugfix #2008
Ton Roosendaal [Sun, 12 Dec 2004 18:16:35 +0000 (18:16 +0000)]
Bugfix #2008

Combination of:
- render movie
- with border set
- and "crop" set
Crashed.

Was due to feeding movie initialize code wrong frame sizes. Another oldie!

Also found that crop+border+parts doesnt work. This now is prevented with
warning and return.

14 years agoAdded missing include path for BIF_toolbox.h.
Simon Clitherow [Sun, 12 Dec 2004 16:24:08 +0000 (16:24 +0000)]
Added missing include path for BIF_toolbox.h.

14 years ago - bug fix reported by LetterRip at IRC (just typo: expant isn't expand)
Jiri Hnidek [Sun, 12 Dec 2004 15:28:38 +0000 (15:28 +0000)]
 - bug fix reported by LetterRip at IRC (just typo: expant isn't expand)

14 years ago- bug fix #1874
Jiri Hnidek [Sun, 12 Dec 2004 13:42:49 +0000 (13:42 +0000)]
- bug fix #1874

  https://projects.blender.org/tracker/?func=detail&aid=1874&group_id=9&atid=125

  normal vectors of vertexes are exported correctly now

14 years agofix for potential crasher. we were returning pointer to a local var
Jean-Luc Peurière [Sun, 12 Dec 2004 13:29:54 +0000 (13:29 +0000)]
fix for potential crasher. we were returning pointer to a local var

14 years agoBug fix #2005
Ton Roosendaal [Sun, 12 Dec 2004 11:19:27 +0000 (11:19 +0000)]
Bug fix #2005

Simple case; make MAXSTACK define for vrml import to allow import up to
750k faces or 1M vertices (was 125k faces, 160k vertices).

14 years agoCtrl+C and CTRL+V copy/paste didn't work for COL buttons ("swatches").
Ton Roosendaal [Sat, 11 Dec 2004 16:33:55 +0000 (16:33 +0000)]
Ctrl+C and CTRL+V copy/paste didn't work for COL buttons ("swatches").
Thanks Chris B for a useful fix!

14 years agoBugfix #1589
Rob Haarsma [Sat, 11 Dec 2004 15:56:01 +0000 (15:56 +0000)]
Bugfix #1589

When the render output directory doesn't exist (on windows) the BLI_recurdir_fileops() function
tries to create a directory with no name. Added check if a name is specified..

14 years agoThe ugly global R.flag was reset to zero, before it was calling functions
Ton Roosendaal [Sat, 11 Dec 2004 15:48:33 +0000 (15:48 +0000)]
The ugly global R.flag was reset to zero, before it was calling functions
that could popup error() boxes. These dont work then, and need to be
disabled by keeping R.flag on R_RENDERING

This is a half fix for a report Rob H works on. Will wait for his test.

14 years agoFix for bug #1823
Ton Roosendaal [Sat, 11 Dec 2004 14:07:38 +0000 (14:07 +0000)]
Fix for bug #1823

Hiding window (Apple-H) caused the modifier to hang when reopened.
Added 1 line that re-reads modifier on "Inputchange" event, which only
is when you switch focus from one app to another.
Might solve more issues reported with 'hanging' keys.

14 years agoFixes, after bug report Stefano:
Ton Roosendaal [Sat, 11 Dec 2004 12:41:51 +0000 (12:41 +0000)]
Fixes, after bug report Stefano:

- Dupli-Frames objects didn't render correct with Motion Blur (they moved!)
- VertexKey on Bezier paths didn't animate the 'twist' rotation. This did
  work for Nurbs paths.

Plus; removed Nabla slider from Stucci, it doesn't work for that texture.

14 years agoAs addition to the use of Colorband for normals;
Ton Roosendaal [Fri, 10 Dec 2004 18:29:16 +0000 (18:29 +0000)]
As addition to the use of Colorband for normals;
- Stucci now accepts it too (for normals and color)
  Note; stucci doesn't return a single value, like marble or wood, that's
  still so, to disable it coloring the "Col" Map input by default.
- Magic texture now accepts Colorband

14 years agoBug fix #1994
Ton Roosendaal [Fri, 10 Dec 2004 14:50:39 +0000 (14:50 +0000)]
Bug fix #1994

Sequence editor crash when you delete Scenes which were used as a strip.
Related to that, file reading code didn't restore pointers for strips
correctly when you save with open "Meta" strip.
First bug 8 year old. Second 1 month. :)

14 years agoDisabled debug printing. Pfft.
Rob Haarsma [Fri, 10 Dec 2004 13:39:05 +0000 (13:39 +0000)]
Disabled debug printing. Pfft.

14 years agoBugfix #1262 bugfix.
Rob Haarsma [Fri, 10 Dec 2004 13:24:56 +0000 (13:24 +0000)]
Bugfix #1262 bugfix.

Path detection was wrong. Grrr, stupid windows paths.

14 years agoBugfix #1262 additions.
Rob Haarsma [Fri, 10 Dec 2004 12:55:53 +0000 (12:55 +0000)]
Bugfix #1262 additions.

When the Quicktime movie output path lacks any path indication, the movie is created in the
executable directory.
Also new, when the Quicktime output movie isn't created for some reason, the rendering will
stop and give an error message (in the console).

14 years agoPatch provided by Chris Burt; constraint name button exceeded actual string
Ton Roosendaal [Fri, 10 Dec 2004 11:49:24 +0000 (11:49 +0000)]
Patch provided by Chris Burt; constraint name button exceeded actual string
size.

14 years agoBugfix #1262
Rob Haarsma [Fri, 10 Dec 2004 01:28:28 +0000 (01:28 +0000)]
Bugfix #1262

Raw fix for the drive letter issue with Quicktime/Windows filenames.
When a drive letter is missing in a filename, it'll use the drive where the executable is.

Fix might be useful for Yafray too, because the extern char bprogname[]; doesn't return
a full path when Blender is started from the console.

14 years agoFixed a crafty little bug that only seemed to show up in 'Rotate Edges'.
Simon Clitherow [Thu, 9 Dec 2004 22:11:40 +0000 (22:11 +0000)]
Fixed a crafty little bug that only seemed to show up in 'Rotate Edges'.

Rotated edges (seemingly on quads only) were not drawn even if
'Draw All Edges' is active.

Finally tracked the bug down to a typo in flag checks! Eeugh, was much
head scratching on this one! :)

14 years agoThree fixes in edge/crease edit for Transform Properties Panel (NKEY)
Ton Roosendaal [Thu, 9 Dec 2004 16:43:37 +0000 (16:43 +0000)]
Three fixes in edge/crease edit for Transform Properties Panel (NKEY)

- code wasn't edge-select aware yet
- the "Median" button now allows to move a "median" correctly around, also
  to 0 or 1 in a single step
- missing undo push  here.

14 years agoBug fix #1995
Ton Roosendaal [Thu, 9 Dec 2004 13:46:38 +0000 (13:46 +0000)]
Bug fix #1995

Unpacking a file with packed sounds didn't save the samples... was due
to *very* weird method samples were put in Blender.

14 years agoI had to change a bit of the stuff I added to get solaris openal working.
Kent Mein [Thu, 9 Dec 2004 13:13:24 +0000 (13:13 +0000)]
I had to change a bit of the stuff I added to get solaris openal working.

I also removed a redundant bit of config stuff for freebsd
that didn't do anything.

Kent

14 years agoThis fixes bug #1990
Kent Mein [Thu, 9 Dec 2004 13:09:11 +0000 (13:09 +0000)]
This fixes bug #1990

It moves targa, bmp, iris and png loading so that were not opening
2 file handles for each file, and made them like the jpeg stuff.

Also cleaned up some minor other stuff.

Kent

14 years agoBug fix #1988, ray-transparency render.
Ton Roosendaal [Thu, 9 Dec 2004 12:06:37 +0000 (12:06 +0000)]
Bug fix #1988, ray-transparency render.

Five fixes in this commit...

- the normals for nurbs surfaces still were calculated pointing wrong in some occasions
- recoded ray-transp rendering to accept normals pointing any direction; it just counts how many times it passes a "glass" layer, and flips normals appropriate then. This means rendering will go fine on models without manually setting the normals. You can also move a camera inside a 'glass' object.
- rendering of the inside part of glass now uses correct normal too... specularity happen on a solid glass inside now.
- And an inside reflected mirror ray will keep bouncing inside glass

Related to rendering localview: old convention to render localview, but with the lamps in the normal layers, has been restored.
Please note; render happens based on active window. You *only* get a localview or 'unlocked layer' render when that 3d window is active = mouse in window.

14 years agoBug fix based on bug report Chris Burt, IRC.
Ton Roosendaal [Wed, 8 Dec 2004 19:08:37 +0000 (19:08 +0000)]
Bug fix based on bug report Chris Burt, IRC.

Appending objects with constraints expands links to objects (according
code) but doesn't give such objects a link to Scene.

Apprently, somewhere in NaN days, someone commented a call, which
already invoked comments... here's the full code + comments now:

/* give a base to loose objects */
give_base_to_objects(G.scene, &(G.main->object));
/* has been removed... erm, why? (ton) */
/* 20040907: looks like they are give base already in append_named_part(); -Nathan L */
/* 20041208: put back. It only linked direct, not indirect objects (ton) */

:-)

14 years agoNarrowed code for restoring UI after undo. It seems still an error in
Ton Roosendaal [Wed, 8 Dec 2004 18:36:48 +0000 (18:36 +0000)]
Narrowed code for restoring UI after undo. It seems still an error in
oops code, having pointers to ID structs that are invalid.

This solves at least it crashing... oops needs to be refreshed once :)

(occurred on testing complex files, with conversion from nurbs=>mesh)

14 years agoBug fix #1987
Ton Roosendaal [Wed, 8 Dec 2004 15:29:47 +0000 (15:29 +0000)]
Bug fix #1987

Halos with texture, but only mapping to "Alpha" and not color, were
rendered black, instead of in material color.

14 years agoBug fix #1985
Ton Roosendaal [Wed, 8 Dec 2004 15:11:52 +0000 (15:11 +0000)]
Bug fix #1985

Using ctrl+up/down in buttons window, didn't use a proper rescale of view
as already works for dragging window edges. Now the 'Full window' action
keeps size nicely.

14 years agoremoved a debug printf. (excuse to check cvs permissions)
Rob Haarsma [Wed, 8 Dec 2004 15:11:38 +0000 (15:11 +0000)]
removed a debug printf. (excuse to check cvs permissions)

14 years agoThis commit makes it so openal finally works on solaris.
Kent Mein [Wed, 8 Dec 2004 14:58:40 +0000 (14:58 +0000)]
This commit makes it so openal finally works on solaris.

Kent

14 years agoEssential cleanup for mess involved with reading files, initializing UI and
Ton Roosendaal [Wed, 8 Dec 2004 14:12:47 +0000 (14:12 +0000)]
Essential cleanup for mess involved with reading files, initializing UI and
patching versions for UI settings.

Currently four different levels of routines for .blend file reading exist;

/* interface level */
1) BIF_init() -> calls 3
2) BIF_read_file() -> calls 11, optional 4
3) BIF_read_homefile() -> calls 11 or 12, and then 4
4) init_userdef_file()

/* kernel level */
11) BKE_read_file() -> calls 21, and then 14
12) BKE_read_file_from_memory() -> calls 22, and then 14
13) BKE_read_file_from_memfile() -> calls 23, and then 14
14) setup_app_data()

/* loader module level */
21) BLO_read_from_file() -> calls 24
22) BLO_read_from_memory() -> calls 24
23) BLO_read_from_memfile() -> calls 24

/* loader module, internal */
24) blo_read_file_internal()

Note:
- BIF_read_homefile() has additional UI initialize calls, like windows fullscreen and executing commandline options

- Reading from memory (12) only happens for the compiled-in .B.blend

- The "memfile" here is a name I gave to the undo "file" structure. Which is constructed out of memory chunks with basic compression features.

- the kernel function setup_app_data() sets globals like "current screen" and "current scene".

So far, so good. The levels as mentioned here clearly distinguish UI from kernel, and should enable for example game loading (runtime) or background (no UI) loading. In the past years however, 'bad level' dependencies were added, and especially the patches for 'file versions' were added in too many places. The latter is evidently a result of the problem that the "UserDef" struct cannot be initialized/patched if there's not a need for a UI.

Here's how the flow goes in four different cases:

----- Starting up Blender, in foreground with UI --------------------

- creator/creator.c, main() -> calls 1
- If the commandline contains a filename, it calls 11

----- Starting up Blender, in background without UI --------------------

- creator/creator.c, main() -> calls 11 if the commandline has a filename

Note: no Userdef is read, nor initialized. Please note that this was already an existing problem for using Yafray, not setting proper file paths in background mode. The Yafray paths don't belong in the User menu.

----- Starting up Blender as a runtime executable --------------------

This only has calls to 22

----- Loading a file from within the UI (with F1, CTRL+O, using pulldowns) -----

Only calls allowed to 2. It detects if a UserDef has been read too, and in that case the init_userdef_file() will be executed.

Hope this is understandable :)

-Ton-

14 years agoBug fix 1982
Ton Roosendaal [Tue, 7 Dec 2004 18:14:03 +0000 (18:14 +0000)]
Bug fix 1982

Three buttons, showing float values, had only precision of 2 digits.
Made it three.

14 years agoBugfix #1981
Ton Roosendaal [Tue, 7 Dec 2004 18:06:13 +0000 (18:06 +0000)]
Bugfix #1981

Pad-minus key didn't work in typemode transform().
Very easy, just flipping an && with || :)

14 years agoSneak in little feature for texture editing pleasure;
Ton Roosendaal [Tue, 7 Dec 2004 17:46:14 +0000 (17:46 +0000)]
Sneak in little feature for texture editing pleasure;

- New channel for "Map to" added, "Warp"
- Use the slider next to the option to set amount of influence the texture
  will have on the coordinates of the next texture.
- Warp uses for this the same values as for Normal or Displacement mapping
- Warp remains active for all channels, until replaced (or zeroed).

14 years agoMore tweaks related to bump mapping quality;
Ton Roosendaal [Tue, 7 Dec 2004 14:46:48 +0000 (14:46 +0000)]
More tweaks related to bump mapping quality;

While going over the code, I found out the "nabla", the size of offset
vectors for calculating derivatives of a texture, is a built in constant.
Even worse, the value was different for new noise types (musgrave etc).
So I've added a new slider for it in the procedural texture panels, which
by default is set to 0.025, the value of the old constant. Also made sure
it works with equal effect in all procedurals.

NOTE: a small Nabla will give sharper, detailed bump, but the effect also
becomes smaller, correct that in the Mapping Panel of materials.

For better & compliant control over the bumpmapping, I've also included
the Colorband output in derivatives calculus, so the bump output then
matches the color created. It's also a nice tool to finetune output of
textures for bumpmapping in general.

Bug fix; clicking on the rightmose 'item' in ColorBand didn't activate it.
Found out the ColorBand was slightly drawn off (2 pixels).

14 years agoAdded support for normalmaps.
Alfredo de Greef [Tue, 7 Dec 2004 05:31:17 +0000 (05:31 +0000)]
Added support for normalmaps.

14 years agoBug fix #1978
Ton Roosendaal [Mon, 6 Dec 2004 19:14:53 +0000 (19:14 +0000)]
Bug fix #1978

Stencil in World didn't work with RGB textures (like what returns from
colorbands).

14 years agoTweaked support for normalmaps to be OK.
Ton Roosendaal [Mon, 6 Dec 2004 18:05:42 +0000 (18:05 +0000)]
Tweaked support for normalmaps to be OK.

http://www.blender3d.org/cms/Normal_Mapping.491.0.html

main changes:
- The "Map Input" in Blender for normals was negated
- Range for Z in normal map is Z (0-1) to Blue (0-255)

14 years agoBug #1970
Ton Roosendaal [Mon, 6 Dec 2004 12:24:10 +0000 (12:24 +0000)]
Bug #1970

Objects being vertex-parented to a mesh, which in turn was being deformed
by a curve or lattice, were never update correctly.
Whilst this is a typical issue for our beloved new Dependency Graph, I
consider it worth at least solving for now. An issue since Blender 1.0
you know. :)

Solution is only working for this specific case; vertex-parent to deformed
object.

14 years agoFix the case when the physics system starves the logic & renderer of CPU time. If...
Kester Maddock [Mon, 6 Dec 2004 11:15:50 +0000 (11:15 +0000)]
Fix the case when the physics system starves the logic & renderer of CPU time.  If this happens, we reduce physics precision to maintain some framerate.

14 years agoFix numerical precision issue in physics. Dividing by a number too close to zero...
Kester Maddock [Mon, 6 Dec 2004 11:10:41 +0000 (11:10 +0000)]
Fix numerical precision issue in physics.  Dividing by a number too close to zero would make the impulse response normal large hence the jittering.

14 years agoSet the default physics tic rate to 90 Hz
Kester Maddock [Mon, 6 Dec 2004 11:01:42 +0000 (11:01 +0000)]
Set the default physics tic rate to 90 Hz

14 years agoDon't try to interpolate from prop ipo actuators
Kester Maddock [Mon, 6 Dec 2004 10:58:38 +0000 (10:58 +0000)]
Don't try to interpolate from prop ipo actuators

14 years agoBug fix #1972
Ton Roosendaal [Mon, 6 Dec 2004 09:57:01 +0000 (09:57 +0000)]
Bug fix #1972

AKEY didn't toggle open/close outliner. It'll be back temporal, until
definitely defined what to do with selections in it.

14 years agoOutliner crash reported bu K-rich;
Ton Roosendaal [Sun, 5 Dec 2004 23:24:43 +0000 (23:24 +0000)]
Outliner crash reported bu K-rich;

- with outliner visible
- alt+d (linked dupli) an armature

14 years agoBugfix: normal mapping for textures wasn't rotated back to view space,
Ton Roosendaal [Sun, 5 Dec 2004 21:49:13 +0000 (21:49 +0000)]
Bugfix: normal mapping for textures wasn't rotated back to view space,
causing weird results on camera moves or object rotations.

Added: support for "normal maps". See for example:
http://members.shaw.ca/jimht03/normal.html

The Image panel in Texture buttons has new option "Normal Map" for it.
When this is used, normals are read straight from RGB values, and blended
with the current normal.

14 years agoBugfix/feat request... in textured view mode the Build Effect didnt show.
Ton Roosendaal [Sun, 5 Dec 2004 21:46:30 +0000 (21:46 +0000)]
Bugfix/feat request... in textured view mode the Build Effect didnt show.

14 years agoReported on IRC;
Ton Roosendaal [Sun, 5 Dec 2004 12:05:28 +0000 (12:05 +0000)]
Reported on IRC;

Converting subsurf to mesh didn't display new Mesh object in correct wire,
when susurf was optimal.

14 years agoBPython, two bug fixes:
Willian Padovani Germano [Sun, 5 Dec 2004 04:01:57 +0000 (04:01 +0000)]
BPython, two bug fixes:
- #1911: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1911&group_id=9
    BOOL properties were returning True always, small mistake in logic.c's getData method.
- #1944: http://projects.blender.org/tracker/?func=detail&atid=125&aid=1944&group_id=9
    G.vd was not being checked against NULL in Window.ViewLayer, causing a crash when this function was called from a command line script.  Now it returns an error in such cases.
- small doc updates, tiny minor change in Object.c.

14 years agoAdded support for the extra texture channels.
Alfredo de Greef [Sun, 5 Dec 2004 03:51:01 +0000 (03:51 +0000)]
Added support for the extra texture channels.

14 years agoFix Action & IPO actuators: (Bugs #1921 & #1920)
Kester Maddock [Sun, 5 Dec 2004 02:50:57 +0000 (02:50 +0000)]
Fix Action & IPO actuators: (Bugs #1921 & #1920)

14 years agoFix for bug #1875:
Kester Maddock [Sun, 5 Dec 2004 00:50:55 +0000 (00:50 +0000)]
Fix for bug #1875:

OpenAL (pthreads) was generating a SIGHUP at alcDestroyContext().

Fix by setting SIGHUP to ignore.

14 years agoSpecial bf-committers request; Lamp/World/Material now each have 10
Ton Roosendaal [Sat, 4 Dec 2004 21:49:02 +0000 (21:49 +0000)]
Special bf-committers request; Lamp/World/Material now each have 10
channels to link texture to.

The amount of code changes seems large, but is mostly getting rind of
hardcoded values (6 and 8) for channels, replacing it with MAX_MTEX.

Further did some fixes;
- Ipo for Lamp showed too many mapping channels
- Texture MapTo buttons for lamp missed the slider to blend texture color
- Lamp texture mapping "View" only worked for Spot, now it uses lamp-
  view vector for all types. (Nice for projections!)

14 years agoWas on my todo; with option "load No UI" the CTRL+X (start over) didnt
Ton Roosendaal [Sat, 4 Dec 2004 17:52:44 +0000 (17:52 +0000)]
Was on my todo; with option "load No UI" the CTRL+X (start over) didnt
load UI either.

(editmesh commit is error in previous commit, but caused no harm)

14 years agoBug fix #1955
Ton Roosendaal [Sat, 4 Dec 2004 14:29:57 +0000 (14:29 +0000)]
Bug fix #1955

Another tweak in the convex formula, replaced a ">" with ">=" for detecting
optimal projection of face in 2d. Solves issue reveiled in Bevel tool,
where it could happen that a face wasn't created.

14 years agoBug fix #1954
Ton Roosendaal [Sat, 4 Dec 2004 12:02:19 +0000 (12:02 +0000)]
Bug fix #1954

Edge render for wire in unified was total mess! Code there apparently never
even tested. Gave wrong rendering and potential crashes.

14 years agoBug #1957
Ton Roosendaal [Sat, 4 Dec 2004 10:51:04 +0000 (10:51 +0000)]
Bug #1957

Blender ALT+Z drawmode didnt support quad lights.

14 years agoUpdate the physics engine: interpolate between frames so track to/camera actuators...
Kester Maddock [Sat, 4 Dec 2004 09:51:04 +0000 (09:51 +0000)]
Update the physics engine: interpolate between frames so track to/camera actuators work properly. (bug #1816)

14 years agoBugfix for #1949:
Brecht Van Lommel [Sat, 4 Dec 2004 00:12:53 +0000 (00:12 +0000)]
Bugfix for #1949:

F11 to switch between render window / main window didn't work anymore in some
window managers (e.g. fluxbox), after fixing it to work in kde.

14 years agoTwo small fixes;
Ton Roosendaal [Fri, 3 Dec 2004 23:22:21 +0000 (23:22 +0000)]
Two small fixes;

- on exit editmode, displist for subsurf was not made, causing static
  particles to calculate wrong
- static particles were not selectable

14 years ago- added undo pushes for buttons invoking file window in scene buttons
Ton Roosendaal [Fri, 3 Dec 2004 22:04:28 +0000 (22:04 +0000)]
- added undo pushes for buttons invoking file window in scene buttons
  (set directory, backbuf, scene)
- small annoyance; after extrude the transform() didn't react to the
  "midtog" feature (middlemouse constraint)

14 years agoBug fix #1952
Ton Roosendaal [Fri, 3 Dec 2004 21:25:56 +0000 (21:25 +0000)]
Bug fix #1952

When rotating camera itself in camera view, and choose local axis rotate,
the camera flipped around. Was due to using viewmat[][] while it changes...

Solved in the simplest elegant way; hope Martin will cope with this in new
transform!

14 years agoBug fix #1945
Ton Roosendaal [Fri, 3 Dec 2004 20:41:53 +0000 (20:41 +0000)]
Bug fix #1945

Undo push missing after "ALT/SHIFT+D and ESC".

14 years agoFixes in static particles. Result of going over details with Chris Burt,
Ton Roosendaal [Fri, 3 Dec 2004 20:22:37 +0000 (20:22 +0000)]
Fixes in static particles. Result of going over details with Chris Burt,
thanks for that!

- static particles that are being deformed (curve/lattice/armature) now
  display correct in 3d window. Only updates when particle system updates
  normally though
- static particles without "animate" set didn't deform even
- static particles used as duplicators had errors with extreme low "life"
  value for particles. Also, still cases could happen with unrotated duplis
  at the end of a static particle line (with Vect option)
- Added tooltip for "Step" option in particles

14 years agoBug fix #1946
Ton Roosendaal [Fri, 3 Dec 2004 18:04:33 +0000 (18:04 +0000)]
Bug fix #1946

Editmode Mesh, edge selectmode, not zbuffer on. Selecting edges didnt give
a small disadvantage to the already selected one, making it hard to select
edges that are extreme close or on top of each other.

14 years agoBug fix #1947
Ton Roosendaal [Fri, 3 Dec 2004 17:03:35 +0000 (17:03 +0000)]
Bug fix #1947

Unified render added sky with alpha=1. Found the way how to fix it, didnt
dare that yesterday. :)
Now sky is rendered with alpha=0, like normal render.

Thanks to the recent reports, a lot of old issues with unified render have
been solved. This is going to be pretty OK!

14 years agoBug fix #1948
Ton Roosendaal [Fri, 3 Dec 2004 16:44:48 +0000 (16:44 +0000)]
Bug fix #1948

When using a backbuffer with alpha, but alpha is not premulled, you can
get weird rendering results with halos or lens flare. This was caused by
optimize rule in alpha routine that assumed alpha==0 means color is zero.
Removed for the the halo case.

14 years agoFixed the very annoying display of User Settings Menu when Blender window
Ton Roosendaal [Fri, 3 Dec 2004 16:32:24 +0000 (16:32 +0000)]
Fixed the very annoying display of User Settings Menu when Blender window
is wider than 1280 pixels. It now keeps scale at 100% then, without zoom.

14 years agoFix for #1951
Ton Roosendaal [Fri, 3 Dec 2004 15:28:48 +0000 (15:28 +0000)]
Fix for #1951

Textbuttons and buttons showing ID names (Objects, etc) were accidentally
also translated. Error since 2.3 recode. :)